Check for Updates and Addons Dialogs Broken

RESOLVED DUPLICATE of bug 467747

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 467747
9 years ago
9 years ago

People

(Reporter: Jay Rossiter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081203 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081203 Shiretoko/3.1b3pre

I've been seeing this problem off and on for a while now.  I originally thought it was tied to an extension (Save Link In Folder) but it has been disabled and I'm still continuing to see the issue.

Sporadically, but more frequently after installing an update, the Check for Updates dialog and the Addons dialog will fail to function correctly.  CfU will simply display a blank dialog in which none of the buttons function (even close) - the only way to close the panel is using the OS-level window close button.

The addons dialog appears with all 'tabs' (Get Add-Ons, Extensions, Themes, Languages, Plugins, Updates) present and every button (Install, Install Updates, Find Updates, Skip, Show Information, Hide Information) enabled.  Nothing in the dialog functions, except for switching "tabs".  All of which are rendered empty.  (However, on the re-render, buttons are displayed appropriately for each tab.)

Reproducible: Sometimes

Steps to Reproduce:
Reproduction steps are not clear.  The problem happens sporadically, and disappears after launching the build in safe mode and then restarting normally.
Please start with a new profile.
Do you see any errors in Tools -> Error Console?
BTW, the tabs Languages and Updates to what extensions do they belong?
(Reporter)

Comment 3

9 years ago
I have to wait for the next replication before I can check the console.

However... I have to ask if you're serious about Updates and Languages?  Those are Firefox native.   Updates only appears if there are extensions that it has located updates for.   Languages only appears in i18n/l10n builds, I assume, since I generally don't see it.
(In reply to comment #3)
> Updates only appears if there are extensions that it has
> located updates for.

Sorry, I thought it was an extension's feature but it belongs indeed to the manager I see now.  I have never used releases so the update function is switched off here since years. :/
(Reporter)

Comment 5

9 years ago
After receiving an updated extension notification this evening (and downloading and restarting), the issue appeared again.  This is what was on the error console (Last to First ordering)

Error: missing ; before statement
Source File: file:///C:/Program%20Files/Mozilla%20Firefox/modules/DownloadUtils.jsm
Line: 76
Source Code:
let kStrings = { 

No chrome package registered for chrome://help/content/contextHelp.js

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIProperties.get]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsBlocklistService.js :: getFile :: line 183"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsBlocklistService.js
Line: 183

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIProperties.get]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsHandlerService.js :: anonymous :: line 912"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsHandlerService.js
Line: 912
(Reporter)

Comment 6

9 years ago
Also, after noticing those errors, I checked the download dialog.  That is also broken.  Empty dialog aside from the buttons.  (No list control, no entries, etc.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 467747
You need to log in before you can comment on or make changes to this bug.