Memory Leak during TopSite Run on http://www.rockyou.com

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

(Blocks: 1 bug, {memory-leak, regression})

Trunk
x86
Mac OS X
memory-leak, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsDocShell (1) leak], URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 351402 [details]
test/leak log

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20081204 Firefox/3.2a1pre BuildID=20081204131556

Memory Leak during the automated Global 500 Testrun on http://www.rockyou.com
Deep 0 Testsrun and latest 1.9.1 Mozilla-Central Debug Build - so Frontpage
only

Requesting blocking 1.9.1 because its a Website from the Global 500 List.
Also i have not seen this leaks on Testruns before, so this is maybe a
regression.

   0 TOTAL                                          28    13659   265820      364 (  957.68 +/-  1029.23)   485315      386 (  603.58 +/-  1106.64)


nsTraceRefcntImpl::DumpStatistics: 681 entries
nsStringStats
 => mAllocCount:          15175
 => mReallocCount:         1773
 => mFreeCount:           15023  --  LEAKED 152 !!!
 => mShareCount:          10856
 => mAdoptCount:           1424
 => mAdoptFreeCount:       1421  --  LEAKED 3 !!!

http://www.rockyou.com: EXIT STATUS: NORMAL (5.998906 seconds)
Flags: blocking1.9.1?

Updated

10 years ago
Whiteboard: [nsDocShell (1) leak]
(Reporter)

Comment 1

9 years ago
not seen during the latest run, so i will mark this wfm for now
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

9 years ago
Flags: blocking1.9.1?
Likely fixed (at least in part) by bug 473845.
(Reporter)

Updated

9 years ago
Blocks: 455273
No longer depends on: 455273
You need to log in before you can comment on or make changes to this bug.