changing style.display from block to table-row in TR doesn't take effect until document.body.focus() called

RESOLVED DUPLICATE of bug 148810

Status

()

RESOLVED DUPLICATE of bug 148810
10 years ago
10 years ago

People

(Reporter: svg, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

changing style.display from block to table-row in TR doesn't take effect until document.body.focus() called

Reproducible: Always

Steps to Reproduce:
1. Load a page with many tables and TR's with style='display:block' (page saved for IE)
2. Try to change style.display to 'table-row' for each TR. Some changes don't take effect unitl alert() or document.body.focus() is called after each style.display='table-row'
Please retest with the latest development build: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
and if the bug is still present and reproducible with a new profile, can you provide a testcase? https://developer.mozilla.org/en/Reducing_testcases
(Reporter)

Comment 2

10 years ago
Created attachment 351609 [details]
Try to uncomment string 65
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables
Version: unspecified → Trunk

Comment 3

10 years ago
Using Firefox trunk on Mac, I see a different layout every time I load the testcase.

I'm guessing this is a manifestation of bug 148810: Gecko gets many dynamic cases involving mis-nested table displays wrong.  Until that bug is fixed, the workaround I recommend is to avoid hitting those cases: use only table-row when you're directly inside table-row-group.
Depends on: 148810
The patch for bug 148810 does in fact fix this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 148810
You need to log in before you can comment on or make changes to this bug.