The default bug view has changed. See this FAQ.

[I18N][ENDER] Chinese pages not displayed properly

VERIFIED FIXED in M11

Status

()

Core
Internationalization
P2
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Teruko Kobayashi, Assigned: buster)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Tested 4-07-11-99 Win32 and Mac build.

After you visit the above page and hit the reload button, the chinese character is displayed fine but
the rest of the page are displayed as squares.
(Reporter)

Updated

18 years ago
Priority: P3 → P2
Summary: Reloading the page will display as squares → Reloading the page will display as squares
Target Milestone: M4
(Reporter)

Comment 1

18 years ago
Same thing happens in http://warp/employees/erik/tests/forms/nbsp/all-charsets/gb2312.cgi page.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
*** This bug has been marked as a duplicate of 4674 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
Hardware: All → PC
(Reporter)

Comment 3

18 years ago
I tested this page in 4-8-10 Win32 and Mac build.  Chinese characters are displayed fine in MAC build.
In Win32 build, the last of 4 Chinese characters is not displayed correctly. I will reopen this and changed the
platform to PC.
(Reporter)

Updated

18 years ago
Assignee: ftang → erik
Status: REOPENED → NEW
(Reporter)

Comment 4

18 years ago
I reassing this bug to Erik.

Updated

18 years ago
Resolution: DUPLICATE → ---
Target Milestone: M4 → M5

Comment 5

18 years ago
some Chinese glyph is missing. i think this is because the font we used to
render CJK Ideographs does not contains all the CJK ideographs glyph. change the
target to M5 and clear the duplicate

Updated

18 years ago
Summary: Reloading the page will display as squares → Windows: Chinese pages not displayed properly

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 6

18 years ago
I tried this on US-NT4 running 4/13 build.
The forms widgets do not display Chinese, but the non-form text next to the check box and radio
buttons render correctly.  Looks like a forms widget problem.

Comment 7

18 years ago
I tried this on US-NT4 running 4/13 build.
The forms widgets do not display Chinese, but the non-form text next to the check box and radio
buttons render correctly.  Looks like a forms widget problem.

Comment 8

18 years ago
Dup of http://bugzilla.mozilla.org/show_bug.cgi?id=3962?

Updated

18 years ago
Assignee: erik → karnaze
Status: ASSIGNED → NEW

Comment 9

18 years ago
Chris, I think the problem here might be that we are using the native widgets
(from the OS) for HTML forms. Are there any plans to switch to GFX-based
widgets for forms? Our GFX can handle Unicode, but native widgets often cannot.

Comment 10

18 years ago
Teruko,  Does this happen with any non-Latin1 pages?  If so, please change
the summary.

Comment 11

18 years ago
Teruko, Are the non-Latin1 display in form widgets problem only on Windows?

Comment 12

18 years ago
Moving to M6 and reassigning to Pierre who is taking over gfx form controls
execept buttons (owned by Eric Vaughan). GFX form controls can be toggled in
viewer and apprunner. They are not bug free. Text fields and text areas will not
be gfx based until Ender is hooked up.
Assignee: karnaze → pierre
Target Milestone: M5 → M6

Updated

18 years ago
Assignee: pierre → ftang

Comment 13

18 years ago
i18n issue: reassigned to ftang

Comment 14

18 years ago
Franck, could you check whether this happens with the GFX form controls?
If only the native controls show the problem, we can close the bug as Invalid or
WontFix, unless you know how to display Chinese characters inside native Mac
controls. Thanks!

Updated

18 years ago
Assignee: ftang → pierre

Comment 15

18 years ago
I think the first thing we need to know is do we plan to switch OFF the native
widgets to GFX based and when ?
1. <INPUT type=button> -> Swtich to GFX base? When (M?)
2. single <SELECT> / <OPTION> ->  Swtich to GFX base? When (M?)
3. multipel <SELECT> / <OPTION> ->  Swtich to GFX base? When (M?)
4. <INPUT type=text> ->  Swtich to ENDER? When (M?)
5. <TEXTAREA> ->  Swtich to ENDER? When (M?)
6. <INPUT type=file> ->  Swtich to GFX base? When (M?)
7. <INPUT type=readonly> ->  Swtich to GFX base? When (M?)
6. <INPUT type=reset> ->  Swtich to GFX base? When (M?)
7. <INPUT type=submit> ->  Swtich to GFX base? When (M?)

If you plan to switch all of them to the GFX based control, then the bug will be
fixed the date you switch to the GFX/ENDER one. Otherwise, you should find a way
to render Unicode in those widget. (for example, draw the button by yourself.
Write a MDEF/LDEF as I did in 3.0). Yes, it is a lot of work, that is why
I suggest (to rods) we switch to the GFX based control last Oct.

reassign this back to pierre since pierre hold the decision of switching to GFX
based control

Updated

18 years ago
Status: NEW → ASSIGNED
OS: Windows NT → All
Hardware: PC → All
Target Milestone: M6

Comment 16

18 years ago
Per discussion with ftang, I confirm that native widgets will not support asian
character sets. There is no defined date yet as to when we will switch to gfx
widgets. Please note that it's a global switch: we can't have some form controls
displayed as native widgets and other ones as gfx widgets.

Gfx widgets can be tested (for what it's worth in their current form) with
Viewer:
- launch Viewer
- under the Debug menu, select "GFX Widgets Mode"
- quit the app
- launch the app again

Updated

18 years ago
Summary: Windows: Chinese pages not displayed properly → [I18N/ENDER] Chinese pages not displayed properly

Updated

18 years ago
Target Milestone: M9

Updated

18 years ago
Summary: [I18N/ENDER] Chinese pages not displayed properly → [I18N][ENDER] Chinese pages not displayed properly

Comment 17

18 years ago
Moving to M15 all the bugs that have a dependancy on GFX widgets and/or Ender.

Updated

18 years ago
Blocks: 7228

Comment 18

18 years ago
I tried this with 1999-06-08-08-M7 on Win95.
I enabled GFX forms widgets (except for text and textarea) by setting the pref:
      user_pref("nglayout.widget.mode", 2);

Except for the text and textareas, all other widgets seem to display Chinese
correctly:
   input types: button, checkbox, radio, reset, submit
   select

Comment 19

18 years ago
Should this be moved back to M10, since buster plans to change the text widgets
to default to GFX in early M10?

Updated

18 years ago
Assignee: pierre → buster
Status: ASSIGNED → NEW

Comment 20

18 years ago
Reassigned to buster who owns gfx text widgets (the other widgets work fine).
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M15 → M10
(Assignee)

Comment 21

18 years ago
set to M10.  When gfx text controls are turned on, this will be fixed.  somebody
in I18N could test this by manually turning gfx text controls if they wanted to.
(Assignee)

Comment 22

18 years ago
moved to M11
(Reporter)

Comment 23

18 years ago
I tested this in 9-10 Win32, Mac, and Linux builds.  This page is displayed correctly in Win32 and Linux build without turning
on the GFX wiget in pref.js.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 24

18 years ago
fixed for gfx text controls.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 25

18 years ago
I verified this in 9-24-08 Mac build.
You need to log in before you can comment on or make changes to this bug.