Closed Bug 468168 Opened 13 years ago Closed 13 years ago

Session restore: click restore twice--it reloads all tabs twice

Categories

(Firefox :: Session Restore, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 3.6a1

People

(Reporter: grenavitar, Assigned: zeniko)

Details

(Keywords: verified1.9.1)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.2a1pre) Gecko/20081203 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.2a1pre) Gecko/20081203 Minefield/3.2a1pre

When the browser crashes and restarts with about:sessionrestore and you click the "restore tabs' button twice (because of system lag, accident, etc.) it reloads all tabs twice.  For me this has always been creating two duplicate windows full of 20 or so tabs.  It seems very unlikely that this behavior would ever

Reproducible: Always

Steps to Reproduce:
1. Get about:sessionrestore screen
2. Click restore button twice
Actual Results:  
All tabs open up twice.

Expected Results:  
All tabs should open up once or give you a warning that you are about to open all of your tabs twice (since steps to reproduce would be overwhelmingly accidental).

This is between minor and trivial.  It has been a minor annoyance twice.  In some sense it could be seen as a 'feature' given more options to the user but if this is the case I recommend a dialog box of some sort asking "are you sure you want to restore the same session twice?" just like we have for when you open all 40 tabs in a folder on the bookmarks toolbar.
Version: unspecified → Trunk
I'm managed to reproduce this. I'd confirm it but I don't have confirm powers.
I tried to reproduce on both Linux and Windows XP, but can't get this. Could be Mac-specific. Shayne, what OS?
Attachment #351678 - Flags: review?(dietrich)
Comment on attachment 351678 [details] [diff] [review]
disable the Restore button when it shouldn't be clicked

r=me
Attachment #351678 - Flags: review?(dietrich) → review+
Assignee: nobody → zeniko
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Mac OS X → All
Priority: -- → P3
Hardware: Macintosh → All
Target Milestone: --- → Firefox 3.1
Keywords: checkin-needed
Attachment #351678 - Flags: approval1.9.1?
http://hg.mozilla.org/mozilla-central/rev/8b0e680a4da8
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: Firefox 3.1 → Firefox 3.2a1
Comment on attachment 351678 [details] [diff] [review]
disable the Restore button when it shouldn't be clicked

a191=beltzner
Attachment #351678 - Flags: approval1.9.1? → approval1.9.1+
Keywords: checkin-needed
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090514 Minefield/3.6a1pre ID:20090514031229

and

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b5pre) Gecko/20090514 Shiretoko/3.5b5pre ID:20090514031203
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.