Last Comment Bug 468173 - Memory Leak during TopSite Run on http://www.wretch.cc
: Memory Leak during TopSite Run on http://www.wretch.cc
Status: RESOLVED WORKSFORME
[nsDocShell leak (1)]
: mlk, regression
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.wretch.cc
Depends on:
Blocks: sisyphus-tracking
  Show dependency treegraph
 
Reported: 2008-12-05 15:31 PST by Carsten Book [:Tomcat]
Modified: 2009-04-19 05:57 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
test/leak log (18.73 KB, text/plain)
2008-12-05 15:31 PST, Carsten Book [:Tomcat]
no flags Details

Description Carsten Book [:Tomcat] 2008-12-05 15:31:33 PST
Created attachment 351625 [details]
test/leak log

Memory Leak during the automated Global 500 Testrun on hhttp://www.wretch.cc
Deep 0 Testsrun and latest 1.9.1 Mozilla-Central Debug Build Build id
:20081204204348 on Mac 10.5- so Frontpage only

Requesting blocking 1.9.1 because its a Website from the Global 500 List.
Also i have not seen this leaks on Testruns before, so this is maybe a
regression.

   0 TOTAL                                          27    11707   519349      330 ( 1794.79 +/-  1603.88)   704965      334 (  794.18 +/-  1406.21)


nsTraceRefcntImpl::DumpStatistics: 693 entries
nsStringStats
 => mAllocCount:          19186
 => mReallocCount:         1688
 => mFreeCount:           19048  --  LEAKED 138 !!!
 => mShareCount:          13437
 => mAdoptCount:           1527
 => mAdoptFreeCount:       1524  --  LEAKED 3 !!!

http://www.wretch.cc: EXIT STATUS: NORMAL (9.106089 seconds)
Comment 1 Carsten Book [:Tomcat] 2009-01-28 14:16:58 PST
not seen during the latest run, so i will mark this wfm for now
Comment 2 Shawn Wilsher :sdwilsh 2009-01-28 14:30:42 PST
Likely fixed (at least in part) by bug 473845.

Note You need to log in before you can comment on or make changes to this bug.