Box around graphics when page is zoomed out (xf86-video-intel)

RESOLVED DUPLICATE of bug 537226

Status

()

RESOLVED DUPLICATE of bug 537226
10 years ago
9 years ago

People

(Reporter: pyther, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.4) Gecko/2008112211 GranParadiso/3.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.4) Gecko/2008112211 GranParadiso/3.0.4

Using the xf86-video-intel driver when a web page is zoomed out (Ctrl + -) there is a box around the graphic which is not suppose to be there.

For example:
Good (Regular Zoom): http://world.pyther.net/files/Firefox/archbbs-good.png
Bad (Zoomed Out): http://world.pyther.net/files/Firefox/archbbs-bad.png

Another example:
Good (Regular Zoom): http://world.pyther.net/files/Firefox/regular_zoom.png
Bad (Zoomed Out): http://world.pyther.net/files/Firefox/zoom_out.png

This behavior does not appear when using the xf86-video-vesa X driver on the same machine. I also have a laptop with nearly all identical packages installed using the ati (fglrx) video module and the problem does not appear.

Reproducible: Always

Steps to Reproduce:
1. Use xf86-video-intel drivers
2. Go to a website (such as http://bbs.archlinux.org)
3. Zoom out (observe box around graphic)
Actual Results:  
Box around graphic

Expected Results:  
No box around graphic

System Information:
Distro: Archlinux (up-to-date, this a rolling release distro)
Firefox: 3.0.4
Xorg: 7.4 (xorg-server 1.5)
Cario: 1.8.4
xf86-video-intel: 2.4.3 (also tried 2.5.1)

Grahpic Card: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

Please let me know what other information you may need.

Comment 1

9 years ago
I get the same bug on the Intel 945GM, except that the box on the intel driver is only on the top and left sides of the image and that lines sometimes appear on either the bottom or right side (but not on both) when using the vesa driver.
duping to confirmed version of bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 537226
You need to log in before you can comment on or make changes to this bug.