ASSERTION: Focus events should not be getting thru when this is null!: 'shell', file nsEventStateManager.cpp, line 1261

RESOLVED WORKSFORME

Status

()

Core
Event Handling
RESOLVED WORKSFORME
9 years ago
5 years ago

People

(Reporter: mats, Unassigned)

Tracking

({assertion})

Trunk
x86
Linux
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
This may be a duplicate of bug 437542, I don't know yet.

STEPS TO REPRODUCE
1. load the first testcase in bug 421839 (download the testcase to your
   computer, because it makes use of enhanced privileges)
2. move the mouse, click on the page and iframe scrollbar, select text,
   drag text etc. repeatedly, as fast as you can

###!!! ASSERTION: Focus events should not be getting thru when this is null!: 'shell', file /usr/moz/hg1/content/events/src/nsEventStateManager.cpp, line 1261

I'm also getting the occasional:
JavaScript error: chrome://global/content/nsDragAndDrop.js, line 458: transferData.first is null

and:
(firefox-bin:21155): Gtk-CRITICAL **: gtk_drag_set_icon_pixbuf: assertion `GDK_IS_DRAG_CONTEXT (context)' failed

PLATFORM AND BUILD TESTED
Firefox trunk debug on Linux with bug 421839 fixed.

Comment 1

5 years ago
Bug 178324 removed the assertion.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.