The richlistbox item for a reminder has two buttons with empty accessible names

RESOLVED WORKSFORME

Status

Calendar
Alarms
RESOLVED WORKSFORME
9 years ago
10 months ago

People

(Reporter: MarcoZ, Assigned: Fallen)

Tracking

(Blocks: 1 bug, {access})

Trunk
x86
Windows Vista
access
Dependency tree / graph
Bug Flags:
blocking-calendar1.0 +

Details

(Whiteboard: [not needed beta][no l10n impact])

(Reporter)

Description

9 years ago
STR:
1. Create an appointment and set a reminder on it.
2. When the reminder comes up, the richlistbox entry for it has two buttons that are unlabelled/have no accessible names.

Updated

9 years ago
Flags: blocking-calendar1.0?
(Assignee)

Comment 1

9 years ago
The buttons are "Dismiss" and "Snooze for". It would be good to fix bug 407915 for this, since that makes the snooze dropdown much more standard and therefore much easier to read a11y-wise.

I agree this is blocking, especially given it should be rather easy to fix, even without bug 407915.
Depends on: 407915

Updated

9 years ago
Flags: blocking-calendar1.0? → blocking-calendar1.0+
(Assignee)

Updated

9 years ago
Assignee: nobody → philipp
(Assignee)

Updated

9 years ago
Whiteboard: [will be fixed by bug 407915]

Updated

9 years ago
Whiteboard: [will be fixed by bug 407915] → [will be fixed by bug 407915][not needed beta][no l10n impact]

Updated

9 years ago
Flags: blocking-calendar1.0+ → wanted-calendar1.0+
(Assignee)

Comment 2

8 years ago
Unfortunately, the patch to bug 407915 doesn't fix this one. I might need some help identifying the problem though. I have the following structure:

<button id="toplevel" type="menu">
  <menupoup>
    <menuitem label="lots of these"/>
    <menuseparator/>
    <hbox>
      <textbox/><menulist>...</menulist><button/>
    </hbox>
  </menupopup>
</button>

I wouldn't be surprised if the inner menulist isn't accessible, but all that the a11y tree shows for the toplevel button is a pushbutton (the button itself) and another pushbutton (the dropmarker of the toplevel button).

Any idea why the dropdown is not being shown?
(Assignee)

Updated

8 years ago
Whiteboard: [will be fixed by bug 407915][not needed beta][no l10n impact] → [not needed beta][no l10n impact]
(Assignee)

Updated

8 years ago
Flags: wanted-calendar1.0+ → blocking-calendar1.0+
Whiteboard: [not needed beta][no l10n impact] → [not needed beta][no l10n impact]

Updated

6 years ago
Blocks: 370226

Updated

6 years ago
No longer blocks: 396347

Comment 3

10 months ago
I can't reproduce anymore since a long time (it was reproducible not only on Windows Vista). Not sure about the patch that fixed the issue, but I think it can be marked as worksforme now.
Maybe someone can confirm.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.