Table contents truncated on print/print-preview, with 2 nested tables & specified-height on outer table.

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: script, Unassigned)

Tracking

({regression, testcase})

Trunk
regression, testcase
Points:
---
Bug Flags:
wanted1.9.1 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

Printing above URL results in only part of the page printed and adding an additional empty leading and trailing page (see attachment). This happens for using print-preview, clicking "print" button on web page, or print to paper. The page prints fine in MSIE.

Reproducible: Always

Steps to Reproduce:
1. go to attached link
2. print-preview, clicking "print" button on web page, or print to paper

Actual Results:  
contents truncated with blank leading and trailing page

Expected Results:  
print two pages

There are several bugs mentioning print problems of similar nature. But I am not sure whether they point to the same problem. Also, most bugs have been open for a looong time. I therefore submit this fresh bug today for Firefox 3.1b2.
(Reporter)

Comment 1

10 years ago
Created attachment 352409 [details]
Print result from Firefox3.1b2
(Reporter)

Comment 2

10 years ago
Created attachment 352416 [details]
Print result from MSIE
(Reporter)

Updated

10 years ago
Severity: normal → major
Component: General → File Handling
Flags: blocking-firefox3.1?
Version: unspecified → 3.1 Branch
--> Core :: Printing
Status: UNCONFIRMED → NEW
Component: File Handling → Printing: Output
Ever confirmed: true
Flags: blocking-firefox3.1?
Product: Firefox → Core
QA Contact: general → printing
Version: 3.1 Branch → Trunk
Flags: blocking1.9.1?
Created attachment 356851 [details]
reduced testcase 1, invalid-html version (ignore me)
Component: Printing: Output → Layout: Tables
Keywords: regression, testcase
OS: Windows XP → All
QA Contact: printing → layout.tables
Hardware: x86 → All
Summary: Print truncates page and adds leading and trailing empty page → Table contents truncated on print/print-preview, with 2 nested tables & specified-height on outer table.
--> Layout::Tables, per reduced testcase 1.  (This seems to be a bug in how we split tables across pages.)
This is a regression WRT Firefox 2.

Both the URL and the original testcase are working in Firefox 2.0.0.18, but are broken in Firefox 3.0.5 and in mozilla-central nightlies.  The build IDs I tested are below:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.18) Gecko/20081029 Firefox/2.0.0.18
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090113 Minefield/3.2a1pre
Created attachment 356853 [details]
reduced testcase 1 (no units on height; ignore me too)

Here's a slightly cleaned-up version of testcase 1. (closing tags & <tbody> & <tr> tags added)
Attachment #356851 - Attachment is obsolete: true
Attachment #356851 - Attachment description: reduced testcase 1 → reduced testcase 1, invalid-html version (ignore me)
Comment on attachment 356853 [details]
reduced testcase 1 (no units on height; ignore me too)

d'oh -- I changed to use style="height: 100" instead of height="100", but I forgot to add units, so the height is ignored in this version.

Third time's the charm... :)
Attachment #356853 - Attachment description: reduced testcase 1 → reduced testcase 1 (no units on height; ignore me too)
Attachment #356853 - Attachment is obsolete: true
Created attachment 356854 [details]
reduced testcase 1
This regressed between these builds:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061207 Minefield/3.0a1
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1
 --> Caused by reflow branch. (bug 300030)
Blocks: 300030
Flags: blocking1.9.1? → wanted1.9.1+

Comment 11

7 years ago
Daniel I see all 300 lines in your testcase with a recent nightly
Me too! Awesome.  The content at the original URL has moved/disappeared, but I think we can mark this as WORKSFORME based on the attached testcase.

Mozilla/5.0 (X11; Linux i686; rv:10.0a1) Gecko/20111022 Firefox/10.0a1
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.