Last Comment Bug 469136 - The font size is too small with the Classic skin (especially in bug comments)
: The font size is too small with the Classic skin (especially in bug comments)
Status: RESOLVED FIXED
: regression
Product: Bugzilla
Classification: Server Software
Component: User Interface (show other bugs)
: 3.2
: All All
: -- normal (vote)
: Bugzilla 3.2
Assigned To: Frédéric Buclin
: default-qa
Mentors:
Depends on: 374020
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 08:16 PST by Graeme Coates
Modified: 2008-12-18 17:09 PST (History)
4 users (show)
LpSolit: approval+
LpSolit: approval3.2+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
v1 (801 bytes, patch)
2008-12-11 08:42 PST, Graeme Coates
LpSolit: review-
Details | Diff | Splinter Review
patch, v1 (533 bytes, patch)
2008-12-11 09:17 PST, Frédéric Buclin
guy.pyrzak: review-
Details | Diff | Splinter Review
patch, v2 (670 bytes, patch)
2008-12-11 22:03 PST, Frédéric Buclin
no flags Details | Diff | Splinter Review
patch, v3 (675 bytes, patch)
2008-12-14 06:39 PST, Frédéric Buclin
guy.pyrzak: review+
Details | Diff | Splinter Review
Screenshot of the comments on all the browsers (397.89 KB, image/png)
2008-12-17 15:53 PST, Guy Pyrzak
no flags Details
Font sizes before the fix (373.19 KB, image/png)
2008-12-17 15:57 PST, Guy Pyrzak
no flags Details

Description Graeme Coates 2008-12-11 08:16:35 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: 3.2

When using IE (v6 - on XPSP3) the comments (on show_bug.cgi) and the mail addresses listed (in process_bug.cgi after a change is made to a bug) are much smaller than in versions prior to v3.2. The fonts are in the region of 8pt size which makes them hard to read when using standard display sizes in IE. Fonts display fine in the new Dusk skin, and look fine in Firefox3 too. 

Adding the following to IE-fixes.css (in skins/custom) seems to make the relevant text much easier to read:

div#bugzilla-body dl dd dl dd {
_font-size: 1.1em;
}

.bz_comment_text {
_font-size: 1.1em;
}

There may well be other areas that I haven't noticed (or had users complain about - I use Firefox so it's not noticable to me).


Reproducible: Always

Steps to Reproduce:
1. Navigate to bug - view comment fields.
2. Change bug and commit - view mail addresses in notification mail summary. 

Actual Results:  
Font size is very small and hard to read. 

Expected Results:  
Font size be more readable as per 3.0 versions.
Comment 1 Graeme Coates 2008-12-11 08:17:38 PST
Setting version and correcting title
Comment 2 Graeme Coates 2008-12-11 08:42:48 PST
Created attachment 352549 [details] [diff] [review]
v1

v1 Patch to template/IE-fixes.css to correct undersized text. Corrects .bz_comment_text and the email address display on process_bug.cgi. 

bz_comment_text font-size corrected separately to .uneditable_textarea.
Comment 3 Frédéric Buclin 2008-12-11 09:13:33 PST
Comment on attachment 352549 [details] [diff] [review]
v1

No, this is not the right fix. The same problem appears with Firefox. I have a patch which fixes this problem.
Comment 4 Frédéric Buclin 2008-12-11 09:15:58 PST
body {font-size: small;} has been added in bug 374020, without any reason AFAIK. The Dusk theme is not affected because it overrides this value.
Comment 5 Frédéric Buclin 2008-12-11 09:17:02 PST
Created attachment 352555 [details] [diff] [review]
patch, v1
Comment 6 Guy Pyrzak 2008-12-11 12:34:24 PST
Comment on attachment 352555 [details] [diff] [review]
patch, v1

This is a huge change that is much too much. Instead I'd suggest 

pre {
  font-size:medium;
}
Comment 7 Guy Pyrzak 2008-12-11 12:55:30 PST
Since dusk seems to be fine we can also use:
.bz_comment {
font-size:9pt;
}

which is what dusk uses for its comments.
Comment 8 A. Shimono [:himorin] 2008-12-11 16:27:13 PST
(In reply to comment #7)
> Since dusk seems to be fine we can also use:
> .bz_comment {
> font-size:9pt;
> }

I think modifing the "font-size" parameter works fine. (like comment #6)
# I've tested at RC1 or 2 age..

But I'd like to argue using the fixed "<numeric> pt" value in our default CSS, at the viewpoint of UE.
Comment 9 Frédéric Buclin 2008-12-11 22:03:48 PST
Created attachment 352676 [details] [diff] [review]
patch, v2

As discussed on IRC.
Comment 10 Max Kanat-Alexander 2008-12-11 22:05:43 PST
This fix doesn't seem quite right, in view of the fact that things work fine in Dusk but not in Classic. What are we doing in Dusk that's different?
Comment 11 Frédéric Buclin 2008-12-11 22:12:32 PST
(In reply to comment #10)
> This fix doesn't seem quite right, in view of the fact that things work fine in
> Dusk but not in Classic. What are we doing in Dusk that's different?

Dusk overrides font sizes defined in global.css, and replaces them by fixed font sizes (e.g. 9pt). But this works in Dusk because it uses fixed font sizes everywhere (not only for comments). We cannot do the same in Classic without fixing all relative font sizes by fixed ones, which is IMO too much changes.
Comment 12 Max Kanat-Alexander 2008-12-11 22:24:10 PST
Okay, agreed. Although I thought we fixed this in some other way for .uneditable_textarea (that I'd think we should do the same with for comments).
Comment 13 Frédéric Buclin 2008-12-14 06:39:27 PST
Created attachment 352908 [details] [diff] [review]
patch, v3

As discussed with pyrzak on IRC, <kbd> also uses monospace, so we must include this tag too, else release notes really look weird with IE.
Comment 14 Guy Pyrzak 2008-12-17 15:53:46 PST
Created attachment 353561 [details]
Screenshot of the comments on all the browsers
Comment 15 Guy Pyrzak 2008-12-17 15:54:30 PST
Comment on attachment 352908 [details] [diff] [review]
patch, v3

looks good to me. It might also fix the other bug that is assigned to me that has the same issue.
Comment 16 Guy Pyrzak 2008-12-17 15:57:08 PST
Created attachment 353564 [details]
Font sizes before the fix
Comment 17 Frédéric Buclin 2008-12-18 17:09:44 PST
tip:

Checking in skins/standard/global.css;
/cvsroot/mozilla/webtools/bugzilla/skins/standard/global.css,v  <--  global.css
new revision: 1.57; previous revision: 1.56
done

3.2:

Checking in skins/standard/global.css;
/cvsroot/mozilla/webtools/bugzilla/skins/standard/global.css,v  <--  global.css
new revision: 1.47.2.6; previous revision: 1.47.2.5
done

Note You need to log in before you can comment on or make changes to this bug.