Please enable drag and drop support for the 'file' input field

RESOLVED DUPLICATE of bug 399917

Status

()

defect
RESOLVED DUPLICATE of bug 399917
11 years ago
11 years ago

People

(Reporter: brett.jr.alton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3

In Firefox 2.0, the user, when working with the "file" field  (think "Browse" button), was able the copy, edit or paste the path of a file. In Firefox 3.0, this option was removed so that the entire bar is highlighted and acts as the "Browse" button when clicked.

I propose to re-add the ability to copy, paste or edit the menu path and add a new feature: allow the dragging and dropping of files from Windows Explorer or Nautilus into the "name" input field. Nautilus should be easy to support because the file path is actually a URI (e.g. file:///home/brett/Desktop/test.txt -- try it: copy a file in Nautilus and paste it into a text editor) 


This is the HTML to the field that I am speaking of:

<form action="" method="post" enctype="multipart/form-data" accept-charset="UTF-8">
    <input size="20" type="file"  />
</form>

Reproducible: Always

Steps to Reproduce:
1.Use Firefox 3.0
2.Go to a form that allows attachments or the uploading of files
3.(a)Try to edit, copy or paste the file path
  (b)Try to drag and drop a file to the input field
Actual Results:  
You can not edit, copy or paste the file path and dragging and dropping does not work.

Expected Results:  
The ability to edit, copy or paste a file path and to drag and drop from a file browser to a "file" input field from a file browser such as Windows Explorer or Nautilus.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 433168
Upduping, I tested for the possibility to invoke the context menu, but the possibility to tab to the field and to paste a path to a file failed earlier. So I'll search for it when I have more time. Sorry.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
I think I found it. 
The feature was removed per bug 258875 so this is possibly a duplicate of Bug 345195. So if you think it is a duplicate can you resolve this bug as such?
Reporter

Comment 4

11 years ago
I apologize, the first two can be considered parents to this bug.

Can we remove all duplicate information and turn this into a "Please enable drag and drop support for the 'file' input field (specifically Nautilus, Windows Explorer, etc)" bug?
Of course; the people in bug 345195 will decide if it also covers drag and drop and if it will be fixed.
Blocks: 258875
Depends on: 345195
Summary: Browse form does not allow editing, copying, pasting or drag & dropping → Please enable drag and drop support for the 'file' input field
Component: File Handling → Content
Product: Firefox → Core
QA Contact: file.handling → content
Component: Content → Layout: Form Controls
QA Contact: content → layout.form-controls
Is this a duplicate of bug 50660?
See also bug 399917.
I assume this is talking about dropping text, not files.  So not bug 50660.  Pretty definitely bug 399917, though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 399917
You need to log in before you can comment on or make changes to this bug.