Firefox 3.0.4 crashes at www.mathrubhumi.com [@ nsSubDocumentFrame::Reflow ]

RESOLVED DUPLICATE of bug 482578

Status

()

--
critical
RESOLVED DUPLICATE of bug 482578
10 years ago
8 years ago

People

(Reporter: xavierakx, Unassigned)

Tracking

({crash, topcrash})

1.9.0 Branch
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

Open 1 or more firefox instances. On one of the instance, open the URL - www.mathrubhumi.com (A newspaper website in an Indian language, Malayalam). The page loads, and within a few seconds, the application crashes, closing down all the firefox instances. 

Reproducible: Always

Steps to Reproduce:
1.Start 1 or more instances Firefox browser. 
2.Open the URL - www.mathrubhumi.com in any one instance of Firefox.
3.Wait for few seconds. 
Actual Results:  
All the firefox instances crash. 

Expected Results:  
It should show the website page, without crashing any of the firefox instances opened.
(Reporter)

Updated

10 years ago
Keywords: crash
(Reporter)

Updated

10 years ago
Summary: All firefox instances crashes when this this URL is opened. → All firefox instances crash when the URL - www.mathrubhumi.com is typed inside the address bar

Comment 2

10 years ago
If you disable the Flash plugin temporarily (Tools->Addons->Plugins)
and then restart Firefox, does it still crash on that site?

Which version of the Flash plugin are you using?
(Reporter)

Comment 3

10 years ago
Crash Report ID : ea8de72b-d99f-4b25-a12f-4b2d92081216

Comment 4

10 years ago
bp-ea8de72b-d99f-4b25-a12f-4b2d92081216
0  	xul.dll  	nsSubDocumentFrame::Reflow  	 mozilla/layout/generic/nsFrameFrame.cpp:544
1 	xul.dll 	nsLineLayout::ReflowFrame 	mozilla/layout/generic/nsLineLayout.cpp:859
2 	xul.dll 	nsBlockFrame::ReflowInlineFrame 	mozilla/layout/generic/nsBlockFrame.cpp:3568
3 	xul.dll 	nsBlockFrame::DoReflowInlineFrames 	mozilla/layout/generic/nsBlockFrame.cpp:3390
4 	xul.dll 	nsBlockFrame::ReflowInlineFrames 	mozilla/layout/generic/nsBlockFrame.cpp:3239
5 	xul.dll 	nsBlockFrame::ReflowLine 	mozilla/layout/generic/nsBlockFrame.cpp:2306
6 	xul.dll 	nsBlockFrame::ReflowDirtyLines 	mozilla/layout/generic/nsBlockFrame.cpp:1886
7 	xul.dll 	nsBlockFrame::Reflow 	mozilla/layout/generic/nsBlockFrame.cpp:953
8 	xul.dll 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
9 	xul.dll 	nsTableCellFrame::Reflow 	mozilla/layout/tables/nsTableCellFrame.cpp:895
10 	xul.dll 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
11 	xul.dll 	nsTableRowFrame::ReflowChildren 	mozilla/layout/tables/nsTableRowFrame.cpp:901
12 	xul.dll 	nsTableRowFrame::Reflow 	mozilla/layout/tables/nsTableRowFrame.cpp:1059
13 	xul.dll 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
14 	xul.dll 	nsTableRowGroupFrame::ReflowChildren 	mozilla/layout/tables/nsTableRowGroupFrame.cpp:455
15 	xul.dll 	nsTableRowGroupFrame::Reflow 	mozilla/layout/tables/nsTableRowGroupFrame.cpp:1360
16 	xul.dll 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
17 	xul.dll 	nsTableFrame::ReflowChildren 	mozilla/layout/tables/nsTableFrame.cpp:2994
18 	xul.dll 	nsTableFrame::ReflowTable 	mozilla/layout/tables/nsTableFrame.cpp:2029
19 	xul.dll 	nsTableFrame::Reflow 	mozilla/layout/tables/nsTableFrame.cpp:1926
20 	xul.dll 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
21 	xul.dll 	nsTableOuterFrame::OuterDoReflowChild 	mozilla/layout/tables/nsTableOuterFrame.cpp:1136
22 	xul.dll 	nsTableOuterFrame::Reflow 	mozilla/layout/tables/nsTableOuterFrame.cpp:1278
23 	xul.dll 	nsBlockReflowContext::ReflowBlock 	mozilla/layout/generic/nsBlockReflowContext.cpp:311
24 	xul.dll 	nsBlockFrame::ReflowBlockFrame 	mozilla/layout/generic/nsBlockFrame.cpp:2979
25 	xul.dll 	nsBlockFrame::ReflowLine 	mozilla/layout/generic/nsBlockFrame.cpp:2251
26 	xul.dll 	nsBlockFrame::ReflowDirtyLines 	mozilla/layout/generic/nsBlockFrame.cpp:1886
27 	xul.dll 	nsBlockFrame::Reflow 	mozilla/layout/generic/nsBlockFrame.cpp:953
28 	xul.dll 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
29 	xul.dll 	nsTableCellFrame::Reflow 	mozilla/layout/tables/nsTableCellFrame.cpp:895
30 	xul.dll 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
31 	xul.dll 	nsTableRowFrame::ReflowChildren 	mozilla/layout/tables/nsTableRowFrame.cpp:901
32 	xul.dll 	nsTableRowFrame::Reflow 	mozilla/layout/tables/nsTableRowFrame.cpp:1059
33 	xul.dll 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
34 	xul.dll 	nsTableRowGroupFrame::ReflowChildren 	mozilla/layout/tables/nsTableRowGroupFrame.cpp:455
35 	xul.dll 	nsTableRowGroupFrame::Reflow 	mozilla/layout/tables/nsTableRowGroupFrame.cpp:1360
36 	xul.dll 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
37 	xul.dll 	nsTableFrame::ReflowChildren 	mozilla/layout/tables/nsTableFrame.cpp:2994
38 	xul.dll 	nsTableFrame::ReflowTable 	mozilla/layout/tables/nsTableFrame.cpp:2029
39 	xul.dll 	nsTableFrame::Reflow 	mozilla/layout/tables/nsTableFrame.cpp:1926
40 	xul.dll 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
41 	xul.dll 	nsTableOuterFrame::OuterDoReflowChild 	mozilla/layout/tables/nsTableOuterFrame.cpp:1136
42 	xul.dll 	nsTableOuterFrame::Reflow 	mozilla/layout/tables/nsTableOuterFrame.cpp:1278
43 	xul.dll 	nsBlockReflowContext::ReflowBlock 	mozilla/layout/generic/nsBlockReflowContext.cpp:311
44 	xul.dll 	nsBlockFrame::ReflowBlockFrame 	mozilla/layout/generic/nsBlockFrame.cpp:2979
45 	xul.dll 	nsBlockFrame::ReflowLine 	mozilla/layout/generic/nsBlockFrame.cpp:2251
46 	xul.dll 	nsBlockFrame::ReflowDirtyLines 	mozilla/layout/generic/nsBlockFrame.cpp:1886
47 	xul.dll 	nsBlockFrame::Reflow 	mozilla/layout/generic/nsBlockFrame.cpp:953
48 	xul.dll 	nsBlockReflowContext::ReflowBlock 	mozilla/layout/generic/nsBlockReflowContext.cpp:311
49 	xul.dll 	nsBlockFrame::ReflowFloat 	mozilla/layout/generic/nsBlockFrame.cpp:5714
50 	xul.dll 	nsBlockReflowState::FlowAndPlaceFloat 	mozilla/layout/generic/nsBlockReflowState.cpp:826
51 	xul.dll 	nsBlockReflowState::AddFloat 	mozilla/layout/generic/nsBlockReflowState.cpp:627
52 	xul.dll 	nsBlockReflowState::InitFloat 	mozilla/layout/generic/nsBlockReflowState.cpp:580
53 	xul.dll 	xul.dll@0x2c0eb2 	
54 	xul.dll 	nsBlockFrame::ReflowInlineFrame 	mozilla/layout/generic/nsBlockFrame.cpp:3568
55 	xul.dll 	nsBlockFrame::DoReflowInlineFrames 	mozilla/layout/generic/nsBlockFrame.cpp:3390
56 	xul.dll 	nsBlockFrame::ReflowInlineFrames 	mozilla/layout/generic/nsBlockFrame.cpp:3239
57 	xul.dll 	nsBlockFrame::ReflowLine 	mozilla/layout/generic/nsBlockFrame.cpp:2306
58 	xul.dll 	nsBlockFrame::ReflowDirtyLines 	mozilla/layout/generic/nsBlockFrame.cpp:1886
59 	xul.dll 	nsBlockFrame::Reflow 	mozilla/layout/generic/nsBlockFrame.cpp:953
60 	xul.dll 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
61 	xul.dll 	nsHTMLScrollFrame::ReflowScrolledFrame 	mozilla/layout/generic/nsGfxScrollFrame.cpp:499
62 	xul.dll 	nsHTMLScrollFrame::ReflowContents 	mozilla/layout/generic/nsGfxScrollFrame.cpp:593
63 	xul.dll 	nsHTMLScrollFrame::Reflow 	mozilla/layout/generic/nsGfxScrollFrame.cpp:794
64 	xul.dll 	nsBlockReflowContext::ReflowBlock 	mozilla/layout/generic/nsBlockReflowContext.cpp:311
65 	xul.dll 	nsBlockFrame::ReflowFloat 	mozilla/layout/generic/nsBlockFrame.cpp:5714
66 	xul.dll 	nsBlockReflowState::FlowAndPlaceFloat 	mozilla/layout/generic/nsBlockReflowState.cpp:826
67 	xul.dll 	nsBlockReflowState::AddFloat 	mozilla/layout/generic/nsBlockReflowState.cpp:627
68 	xul.dll 	nsBlockReflowState::InitFloat 	mozilla/layout/generic/nsBlockReflowState.cpp:580
69 	xul.dll 	xul.dll@0x2c0eb2 	
70 	xul.dll 	nsBlockFrame::ReflowInlineFrame 	mozilla/layout/generic/nsBlockFrame.cpp:3568
71 	xul.dll 	nsBlockFrame::DoReflowInlineFrames 	mozilla/layout/generic/nsBlockFrame.cpp:3390
72 	xul.dll 	nsBlockFrame::ReflowInlineFrames 	mozilla/layout/generic/nsBlockFrame.cpp:3239
73 	xul.dll 	nsBlockFrame::ReflowLine 	mozilla/layout/generic/nsBlockFrame.cpp:2306
74 	xul.dll 	nsBlockFrame::ReflowDirtyLines 	mozilla/layout/generic/nsBlockFrame.cpp:1886
75 	xul.dll 	nsBlockFrame::Reflow 	mozilla/layout/generic/nsBlockFrame.cpp:953
76 	xul.dll 	nsBlockReflowContext::ReflowBlock 	mozilla/layout/generic/nsBlockReflowContext.cpp:311
77 	xul.dll 	nsBlockFrame::ReflowFloat 	mozilla/layout/generic/nsBlockFrame.cpp:5714
78 	xul.dll 	nsBlockReflowState::FlowAndPlaceFloat 	mozilla/layout/generic/nsBlockReflowState.cpp:826
79 	xul.dll 	nsBlockReflowState::AddFloat 	mozilla/layout/generic/nsBlockReflowState.cpp:627
80 	xul.dll 	nsBlockReflowState::InitFloat 	mozilla/layout/generic/nsBlockReflowState.cpp:580
81 	xul.dll 	xul.dll@0x2c0eb2 	
82 	xul.dll 	nsBlockFrame::ReflowInlineFrame 	mozilla/layout/generic/nsBlockFrame.cpp:3568
83 	xul.dll 	nsBlockFrame::DoReflowInlineFrames 	mozilla/layout/generic/nsBlockFrame.cpp:3390
84 	xul.dll 	nsBlockFrame::ReflowInlineFrames 	mozilla/layout/generic/nsBlockFrame.cpp:3239
85 	xul.dll 	nsBlockFrame::ReflowLine 	mozilla/layout/generic/nsBlockFrame.cpp:2306
86 	xul.dll 	nsBlockFrame::ReflowDirtyLines 	mozilla/layout/generic/nsBlockFrame.cpp:1886
87 	xul.dll 	nsBlockFrame::Reflow 	mozilla/layout/generic/nsBlockFrame.cpp:953
88 	xul.dll 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
89 	xul.dll 	nsHTMLScrollFrame::ReflowScrolledFrame 	mozilla/layout/generic/nsGfxScrollFrame.cpp:499
90 	xul.dll 	nsHTMLScrollFrame::ReflowContents 	mozilla/layout/generic/nsGfxScrollFrame.cpp:593
91 	xul.dll 	nsHTMLScrollFrame::Reflow 	mozilla/layout/generic/nsGfxScrollFrame.cpp:794
92 	xul.dll 	nsBlockReflowContext::ReflowBlock 	mozilla/layout/generic/nsBlockReflowContext.cpp:311
93 	xul.dll 	nsBlockFrame::ReflowBlockFrame 	mozilla/layout/generic/nsBlockFrame.cpp:2979
94 	xul.dll 	nsBlockFrame::ReflowLine 	mozilla/layout/generic/nsBlockFrame.cpp:2251
95 	xul.dll 	nsBlockFrame::ReflowDirtyLines 	mozilla/layout/generic/nsBlockFrame.cpp:1886
96 	xul.dll 	nsBlockFrame::Reflow 	mozilla/layout/generic/nsBlockFrame.cpp:953
97 	xul.dll 	nsBlockReflowContext::ReflowBlock 	mozilla/layout/generic/nsBlockReflowContext.cpp:311
98 	xul.dll 	nsBlockFrame::ReflowBlockFrame 	mozilla/layout/generic/nsBlockFrame.cpp:2979
99 	xul.dll 	nsBlockFrame::ReflowLine 	mozilla/layout/generic/nsBlockFrame.cpp:2251
100 	xul.dll 	nsBlockFrame::ReflowDirtyLines 	mozilla/layout/generic/nsBlockFrame.cpp:1886
121 	xul.dll 	nsViewManager::EndUpdateViewBatch 	mozilla/view/src/nsViewManager.cpp:1972
122 	xul.dll 	nsIViewManager::UpdateViewBatch::EndUpdateViewBatch 	nsIViewManager.h:379
123 	xul.dll 	PresShell::DoFlushPendingNotifications 	mozilla/layout/base/nsPresShell.cpp:4591
124 	xul.dll 	PresShell::ReflowEvent::Run 	mozilla/layout/base/nsPresShell.cpp:6153
125 	xul.dll 	nsThread::ProcessNextEvent 	mozilla/xpcom/threads/nsThread.cpp:510
126 	xul.dll 	nsBaseAppShell::Run 	mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:170
127 	nspr4.dll 	PR_GetEnv 	
128 	firefox.exe 	wmain 	mozilla/toolkit/xre/nsWindowsWMain.cpp:87
129 	firefox.exe 	firefox.exe@0x217f 	
130 	kernel32.dll 	kernel32.dll@0x17066
Summary: All firefox instances crash when the URL - www.mathrubhumi.com is typed inside the address bar → Firefox 3.0.4 crashes at www.mathrubhumi.com [@ nsSubDocumentFrame::Reflow(nsPresContext*, nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned int&) ]
Version: unspecified → 3.0 Branch
(Reporter)

Comment 5

10 years ago
>> If you disable the Flash plugin temporarily (Tools->Addons->Plugins)
>> and then restart Firefox, does it still crash on that site?

No. It doesn't crash when the Flash plug in is disabled. 

>> Which version of the Flash plugin are you using?

Shockwave Flash 10.0 r12

Comment 6

10 years ago
I've yet to be able to reproduce this. (on Linux or Windows XP) Seems to work fine for me, though in my WinXP install I don't have the fonts the page wants.

Can you provide more precise steps to reproduce this?
Summary: Firefox 3.0.4 crashes at www.mathrubhumi.com [@ nsSubDocumentFrame::Reflow(nsPresContext*, nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned int&) ] → Firefox 3.0.4 crashes at www.mathrubhumi.com [@ nsSubDocumentFrame::Reflow ]

Updated

10 years ago
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: 3.0 Branch → 1.9.0 Branch

Comment 7

10 years ago
Also, did you check to make sure it still crashes in Firefox safe mode, as is stated at the top of the page linked to in comment 1?
http://support.mozilla.com/en-US/kb/Safe+Mode
This crash has appeared as a topcrash in Firefox 3.0.7. It's currently #1. The stack from bp-ea8de72b-d99f-4b25-a12f-4b2d92081216 matches the stack from bp-e4bf81cb-ebf6-4de7-9b27-1dca62090308 until frame 8.

This crash didn't appear in the top 100 for Firefox 3.0.6, though there were ~450 crashes in the last week. (The #100 topcrash had ~700 crashes.)

This might have appeared at the beginning of the 3.0.6 cycle and we just missed it, in which case it could be a crash on update or migration.

Confirming based on topcrash data.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.9.0.8?
Keywords: topcrash
OS: Windows XP → All
Hardware: x86 → All

Comment 9

10 years ago
Repeatable crash on Firefox 3.0.7 with Firebug 1.3.3: http://crash-stats.mozilla.com/report/index/8c80707a-856a-4e53-b8e2-42cc02090310

Repro steps:
1. Enable Firebug
2. Visit any product page on target: http://www.target.com/dp/B0000E60TV
3. Make sure you are not signed in
4. Click Add to Club Wedd

Updated

10 years ago
Blocks: 482578
There's also a reliable STR in bug 482578 which is a likely dupe.
Duping this forward to bug 482578 since there is reliable STR there and it looks to be the same crash.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: blocking1.9.0.8?
Resolution: --- → DUPLICATE
Duplicate of bug: 482578

Comment 12

10 years ago
Hi

I dont have access to bug 482578 ( So I dont know the status of that bug), but this problem is occuring in firefox 3.0.9. I havent faced this problem earlier and this is the first time firefox crashing as soon as I open www.mathrubhumi.com.

Thanks
Saju
(In reply to comment #12)
> Hi
> 
> I dont have access to bug 482578 ( So I dont know the status of that bug), (...)

If you mouse over phrase "bug 482578" in Bugzilla, you will notice status of the bug (it is "NEW" at the moment).
(BTW - I don't know if this behaviour is a bug or a feature of Bugzilla software ;-))
(Assignee)

Updated

8 years ago
Crash Signature: [@ nsSubDocumentFrame::Reflow ]
You need to log in before you can comment on or make changes to this bug.