The default bug view has changed. See this FAQ.

Update Public Suffix (effective TLD) list (4)

RESOLVED FIXED

Status

()

Core
Networking
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: David Triendl, Assigned: Peter Kasting)

Tracking

({verified1.9.0.16, verified1.9.1})

Trunk
verified1.9.0.16, verified1.9.1
Points:
---

Firefox Tracking Flags

(status1.9.2 beta2-fixed, status1.9.1 .6-fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
Created attachment 353265 [details] [diff] [review]
Update for public suffix list

This is the 4th round of updating the public suffix list (network/dns/src/effective_tld_names.dat).

Changes:
* Update .vi
* Update .iq
* Update .cr
* Update .ru (thanks to Zac)
* Update .jp as requested by registry (thanks to Yoshiro Yoneya)

As I updated .ru to the official registry list, I'll make bug 430971 a duplicate of this bug.
Attachment #353265 - Flags: review?(gerv)
(Reporter)

Updated

8 years ago
Duplicate of this bug: 430971
Comment on attachment 353265 [details] [diff] [review]
Update for public suffix list

Removing names from the list is obviously more controversial than adding new ones. Can you explain how you know that it's OK to remove those .ru and .vi entries?

Gerv
We dropped this one on the floor :-( Some of these changes have been made, but not all. The patch needs refreshing.

Gerv
Peter, Adam: are either of you able to take this on?

Gerv
(Assignee)

Comment 5

8 years ago
I can look up Wikipedia entries and registry homepages for the changes here if you want.  I'm not sure whether that's sufficient for you; what would you like to see from someone who "takes this on"?
What I was hoping for was for someone to look through David's patch, work out which of the changes he made have not yet been included in the current list, confirm those changes are still valid (which is fairly likely) and produce a new patch against the trunk for me to review :-)

Gerv
(Assignee)

Comment 7

8 years ago
I'll try to do this.
Assignee: david+mozilla → pkasting
(Assignee)

Comment 8

8 years ago
Created attachment 401265 [details] [diff] [review]
Updated patch

I double-checked all the old changes and added a few more.

Here are the differences from the old patch:
* .cr changes had already been applied, but with mismatched line endings; fixed those
* Modified comments slightly for clarity/accuracy
* Attempted to update .pa/.sa, about which we've debated in the past; the current .sa rules are quite clear, while the .pa rules are slightly less so (all public documentation agrees, but what it agrees on doesn't quite cover all of reality)
* Avoided collapsing Russian geographic rules from two sections to one, since the registrar didn't, and this makes both the patch diff and the diff of our list against the registrar slightly saner.  I did reorder a few rules in the name of alphabetization.
* Removed some inaccurate comments in the .us section and tried to replace with an accurate one
Attachment #353265 - Attachment is obsolete: true
Attachment #353265 - Flags: review?(gerv)
(Assignee)

Updated

8 years ago
Attachment #401265 - Flags: review?(gerv)
Comment on attachment 401265 [details] [diff] [review]
Updated patch

I think that, in the name of future-proofing the list, if edu.vi and gov.vi are reserved, then we should add them. The only thing that could go wrong is if someone set up a website at http://edu.vi. And if they are reserved, that's not going to happen. 

What happened to tagil.ru?

Gerv
(Assignee)

Comment 10

8 years ago
(In reply to comment #9)
> (From update of attachment 401265 [details] [diff] [review])
> I think that, in the name of future-proofing the list, if edu.vi and gov.vi are
> reserved, then we should add them.

The problem with this is that the .vi registrar also lists thousands of other domains that are "reserved".  I feel like we should be consistent, and I don't see any benefit to getting the others.  If you can't purchase .edu.vi, and it's never been available in years, I'd prefer the simpler and more accurate file for now.

> What happened to tagil.ru?

It is not listed on the registrar page.  Considering that it was the _only_ existing domain not listed, I assumed I wasn't just looking at a partial list.
Comment on attachment 401265 [details] [diff] [review]
Updated patch

r=gerv.

Gerv
Attachment #401265 - Flags: review?(gerv) → review+
Let's get this on the trunk to start with, and then think about branches. Peter: do you need me to check it in?

Gerv
(Assignee)

Comment 13

8 years ago
(In reply to comment #12)
> Peter: do you need me to check it in?

Sure, go ahead.  Any chance you could also r+/checkin bug 513834?  We (Chromium folks) are still interested in that.
http://hg.mozilla.org/mozilla-central/rev/cac6c26d9e5a

After a couple of days, we'll nominate this for the two branches.

Gerv
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Nominating for branches. Companion bug 513834. Justification: bringing public suffix list closer to reality.

Gerv
status1.9.1: --- → ?
Flags: wanted1.9.2?
Attachment #401265 - Flags: approval1.9.2?
Attachment #401265 - Flags: approval1.9.1.5?
Attachment #401265 - Flags: approval1.9.0.16?
Comment on attachment 401265 [details] [diff] [review]
Updated patch

Approved for 1.9.1.5 and 1.9.0.16, a=dveditz for release-drivers
Attachment #401265 - Flags: approval1.9.1.5?
Attachment #401265 - Flags: approval1.9.1.5+
Attachment #401265 - Flags: approval1.9.0.16?
Attachment #401265 - Flags: approval1.9.0.16+

Updated

8 years ago
Attachment #401265 - Flags: approval1.9.2? → approval1.9.2+
Checked in on all branches.

Checking in netwerk/dns/src/effective_tld_names.dat;
/cvsroot/mozilla/netwerk/dns/src/effective_tld_names.dat,v  <--  effective_tld_names.dat
new revision: 1.11; previous revision: 1.10

http://hg.mozilla.org/releases/mozilla-1.9.1/rev/3aa22391ebe7d5aac6d56813418092b329d92cac

http://hg.mozilla.org/releases/mozilla-1.9.2/rev/22e923bf460b4de772063d121d42ff40a5ce1948

Gerv
status1.9.1: ? → .5-fixed
status1.9.2: --- → final-fixed
Flags: wanted1.9.2?
Keywords: fixed1.9.0.16
Verified for 1.9.0.16 and 1.9.1.6 in source. Nothing else for QA here.
Keywords: fixed1.9.0.16 → verified1.9.0.16, verified1.9.1
You need to log in before you can comment on or make changes to this bug.