Need toolbar borders in SeaMonkey

RESOLVED FIXED in seamonkey2.0a3

Status

SeaMonkey
Themes
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: stefanh, Assigned: stefanh)

Tracking

({classic, regression})

Trunk
seamonkey2.0a3
x86
Mac OS X
classic, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

981 bytes, patch
Karsten Düsterloh
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

9 years ago
Created attachment 353481 [details] [diff] [review]
Get back borders

toolbar top/bottom borders has been removed in toolkit's pinstripe/global/toolbar.css. Since we're currently using -moz-appearance: none for the toolbar element, we relied on those borders. Now there's nothing that, for example, separates PT from the main toolbar. The attached patch fixes this. It also removes the comment about the override since I think it is a bit outdated (-moz-appearance: toolbar; will give you a dark gray toolbar and not a striped one and mac apps in general has a unified toolbar these days).
Attachment #353481 - Flags: review?(mnyromyr)
(Assignee)

Comment 1

9 years ago
Note that we will use a unified toolbar quite soon, so this is a temporary fix. The reason I think we should do this is that it might take a couple of weeks or more before we have our new toolbar look.

Updated

9 years ago
Attachment #353481 - Flags: review?(mnyromyr) → review+

Comment 2

9 years ago
Comment on attachment 353481 [details] [diff] [review]
Get back borders

Looking at eg. Error Console or Venkman, we have a bunch of toolbar theming problems, too... *sigh*
(Assignee)

Updated

9 years ago
Attachment #353481 - Flags: superreview?(neil)

Updated

9 years ago
Attachment #353481 - Flags: superreview?(neil) → superreview+
(Assignee)

Comment 3

9 years ago
Pushed changeset e714e22e2468 to comm-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: regression
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.