Closed Bug 470258 Opened 13 years ago Closed 13 years ago

Remove License Text from Major Update Window

Categories

(Release Engineering :: General, defect, P2)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cbook, Assigned: nthomas)

References

Details

We found this during the Partner Major Update work from Firefox 2.0.0.20 to 3.0.5 - during the Major Update Process you need to accept a license for Firefox 3.x 

This should be removed because of the new about:rights.

Also a second problem that is causing the license,is that you don't get a about:rights window after the Major Update Window, because you have already accepted the License (with the MU Dialog).
Depends on: 462254
The license in the major update dialog comes from a url specified in the updates xml file. We might be able to use the about:rights content and present that instead.
To not display it the update xml should not have licenseURL defined.

Not an app update problem so resolving -> invalid. Please either file a new bug against the correct component or reopen this bug and assign it to the right component.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
btw: reasons to keep the option to display a license in app update

a) other apps use app update that don't have about:rights.
b) even if about:rights was implemented in our other apps there can be other apps that might need to display a licenseURL as was the requirement for Firefox previously. It is also an opt-in option to display a license and this is accomplished by specifying a licenseURL in the update xml.
c) This is against stable 3.0.x and we shouldn't change / remove a bunch of client code on a stable branch when there is already an option to not display it.

Also, displaying about:rights from app update is a non-starter since the rights we would need to display are for the version that is available and not the version installed.
The only area here I'm fuzzy on is why the about:rights infobar doesn't display on first-run. If removing the licenseURL resolves the EULA being displayed as a conditional, awesome, but does the updater set browser.rights.3.shown to true?
(In reply to comment #4)
> The only area here I'm fuzzy on is why the about:rights infobar doesn't display
> on first-run. If removing the licenseURL resolves the EULA being displayed as a
> conditional, awesome, but does the updater set browser.rights.3.shown to true?
Not having a licenseURL defined does not display the license and this has always behaved this way. This is why a license isn't displayed for minor and nightly updates.

App update doesn't set prefs for about:rights and doesn't need to. Just as the extension manager code and other code performs operations on upgrade so should about:rights if it needs to.
As a test, I've removed the licenceURL for Google/win32/en-US. Please retest with that and I'll fix up all the snippets if that's enough.
Assignee: nobody → nthomas
Status: RESOLVED → REOPENED
Component: Application Update → Release Engineering
Priority: -- → P2
Product: Toolkit → mozilla.org
QA Contact: application.update → release
Resolution: INVALID → ---
Version: unspecified → other
So, bug 462254 (specifically attachment 346348 [details] [diff] [review]) is what's involved here. When the browser starts up, it checks to see if your profile has previously been used (ie, this isn't a freshly created first-install profile). If that's the case, we set the browser.rights.3.shown pref to true.

The main about:rights code (bug 456439) runs after this, looks for the browser.rights.3.shown pref, and if already set does nothing. [Note that the version number in this pref is independent of the Firefox release version, they just happen to currently overlap. The upgrade code I mentioned in the last paragraph will always set "3", the main about:rights code will always check the current version. If we go to version 4 at some point, it will be shown to everyone, even upgraders.]

My understanding was that we didn't want to nag existing users with the new about:rights notification. IE, the concern was about getting rid of the EULA for people installing Firefox for the first time, not alerting current users to a change of terms.

(In reply to comment #4)
> The only area here I'm fuzzy on is why the about:rights infobar doesn't display
> on first-run. If removing the licenseURL resolves the EULA being displayed as a
> conditional, awesome, but does the updater set browser.rights.3.shown to true?

Removing |licenseURL| from the update xml won't cause the about:rights notification to be shown after upgrade, for the reason noted above.
(In reply to comment #6)
> As a test, I've removed the licenceURL for Google/win32/en-US. Please retest
> with that and I'll fix up all the snippets if that's enough.

Note, this works fine/as expected, no licence window!
Ok, so we just need a decision about if we want to port the about:rights content to a webpage for major updates to 3.0.5. We're hoping to ship some partner major updates tomorrow, so no pressure!
I should think that we wouldn't want to send any licenseURL, even with the about:rights content.
Spoke with Harvey about it, and removal is fine (and preferred, because it gets referred to as a EULA). I'll open a bug to modify the text label there, as well.
Fixed in the partner builds we shipped from 2.0.0.20 to 3.0.5, and I'll remove the licenceURL stuff from the next vanilla major update too.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
verified fixed for the Partner Builds ! 

For the Vanilla Builds: Al, Juan: please look during your testing also that the LicenceURL is removed!
Status: RESOLVED → VERIFIED
I can confirm verified on vanilla major updates going from 2.0.0.20 to 3.0.5, after testing en-US and one locale on all three platforms on releasetest. The license dialog does not come up during the major update offer or subsequent steps in the process.
(In reply to comment #6)
> As a test, I've removed the licenceURL for Google/win32/en-US. Please retest
> with that and I'll fix up all the snippets if that's enough.

I have a question: do "partner builds" (including Google) also show toolbar on first run with the text "%S is free and open software from the non-profit Mozilla Foundation."?

BTW - I'd be grateful if someone answers my questions posted here:
https://wiki.mozilla.org/Talk:Releases/Fx_3.0.7_Partners
The "Know Your Rights" infobar will appear on firstrun or update to the browser.rights.version in any branded build. Since partner repacks are based on the official, branded builds, the infobar appears.

WRT to the questions you pose, I'm hoping to have answers posted publicly by the end of this week.
(In reply to comment #16)
> The "Know Your Rights" infobar will appear on firstrun or update to the
> browser.rights.version in any branded build. Since partner repacks are based on
> the official, branded builds, the infobar appears.

I guess Partner Repack for Google includes Google Toolbar, which is a closed source software (*), so how the browser still makes claims about "free and open software..."? I think it is extremely dishonest (if it is indeed the case).

(*) For example, EULA of Google Toolbar includes this wording: "You may not (and you may not permit anyone else to) copy, modify, create a derivative work of, reverse engineer, decompile or otherwise attempt to extract the source code of the Software or any part thereof, unless this is expressly permitted or required by law, or unless you have been specifically told that you may do so by Google, in writing."
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.