SQLITE_CORRUPT in some user Profiles

RESOLVED DUPLICATE of bug 464486

Status

()

RESOLVED DUPLICATE of bug 464486
10 years ago
9 years ago

People

(Reporter: bruno, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008121523 Firefox/3.0.4 Flock/2.0.3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008121523 Firefox/3.0.4 Flock/2.0.3pre

Some of our Flock users are reporting problems that we traced back to a SQLITE_CORRUPT places.sqlite.

They tend to be on Windows and Flock version is based on Firefox 3.0.2.

We also experienced SQLITE_CORRUPT in our Flock RDF Sqlite database. This database has a fixed table structure that never changes.

Reproducible: Couldn't Reproduce




I can send you a couple of corrupted profiles if this can help you.
(Reporter)

Comment 1

10 years ago
Unlike bug 404695, no places.sqlite.corrupt was created
Version: unspecified → 3.0 Branch
See bug 464486 and bug 414715 for the work being done for 3.1, firefox had also been swamped with these reports.
Component: Bookmarks & History → Places
QA Contact: bookmarks → places
(Reporter)

Comment 3

10 years ago
Thank you very much Natch.
Depends on: 464486
sqlite_corrupt can actually happen not using PRAGMA synchronous=FULL, we actually are using normal, corruption is usually caused by power failure, io errors or (maybe) strange crashes... notice also some old sqlite version could contain some bug that in certain circumstances could cause corruption, latest version (IIRC used in 3.05 and 3.1) corrects some of them.
Bruno, do you need this separate bug or can we dupe it to bug 464486 since are practically investigating the same issue?
Whiteboard: dupe to 464486?
(Reporter)

Comment 6

10 years ago
Yes, we can mark it as duplicate. Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
No longer depends on: 464486
Resolution: --- → DUPLICATE
Duplicate of bug: 464486
Whiteboard: dupe to 464486?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.