tab pane only supports 4 tabs, yet appears to support more

VERIFIED WORKSFORME

Status

Fennec Graveyard
General
VERIFIED WORKSFORME
9 years ago
8 years ago

People

(Reporter: jmaher, Assigned: Gavin)

Tracking

(Blocks: 2 bugs)

Dependency tree / graph

Details

(Reporter)

Description

9 years ago
In fennec when you create more than 4 tabs, it creates another column on the tab pane.  I had seen for a while where the tab pane would scale the images and its own size to display multiple rows of tabs successfully.  

Now It remains the same size, does not modify the tab preview size and only shows 1.25 columns.  this is enough to know there is more than the 4 tabs, but you really only see enough of the tab to make out the X.
First thoughts are that this is a regression from widgetstack landing. Previously, the width of the tab strip would grow to accommodate more tabs. I don't think that is happening now.
(Reporter)

Comment 2

9 years ago
To be honest, I am unable to read the content inside the mini preview of the tabs, so maybe we should do something else?  Also on a smaller screen this method won't work.

One idea that I have would be to have the list of tabs be like the awesome bar where it gives you a list (maybe panning?) of the page titles/urls.  I don't think the favicon is necessary but that is another piece of data that is normally small and easy to understand for the end user.

Another idea is to have the tabs scroll up/down (or maybe left/right) and only allow the user to move to the next tab in the list.  I know this is not ideal, but it is better than we currently have.  This idea only came to my mind since the tab switching is so fast!

Lastly is an idea similar to the CTRL+TAB switching that we sort of have for firefox.  We could tap once on a tab, show a large preview that they could understand, and then a second tap would switch to the tab.  This might be confusing to the end user since a single tap doesn't take them to the tab.
(Reporter)

Updated

9 years ago
Blocks: 473596
Blocks: 477628

Updated

9 years ago
tracking-fennec: --- → 1.0+
Duplicate of this bug: 491486

Updated

9 years ago
Assignee: nobody → gavin.sharp
the sidebar area should be getting larger to accommodate two columns of tab thumbnails.
(Reporter)

Comment 5

9 years ago
will that work in portrait mode on an omnia?  I assume we are looking at a maximum of 8 tabs?  That might be good to set to reduce memory (assuming we can set a maximum number of tabs).  Maybe panning in the tab pane is necessary?
This works now that tiles have landed
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

8 years ago
verified with maemo nightly from 20090818
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.