content with overflow!=visible remains after scrolling

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
25 days ago

People

(Reporter: karlt, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph
Bug Flags:
wanted1.9.2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
(Copied and editted from https://bugzilla.redhat.com/show_bug.cgi?id=476944)

Steps to Reproduce:
1. Go to http://planet.gnome.org/
2. Wait until the whole page loads
3. Press the "End" button on your keyboard
4. DON'T TOUCH ANYTHING

Actual results:
Some of the text from the top of the page is displayed at the bottom, together
with its light background. It goes away on repaint (when you switch to another application and come back).

Expected results:
Only the stuff from the bottom of the page (dark background) should be
displayed.
Flags: blocking1.9.2?
(Reporter)

Updated

10 years ago
Blocks: 444238
It seems to happen when the page is big enough. If this happens I get this warning:

WARNING: Clamping huge window height: file nsWindow.cpp, line 4246

and a context of firefox window is blank after switch to other application and back. I'll attach some minimal test case.
(Reporter)

Comment 3

10 years ago
Thanks for the testcase, Martin.
That is a good testcase for the change in behavior since FF3 referenced in bug 444238, but it doesn't display the issues of comment 0 in FF3.

The two bug reports are related but I suspect they may be different.
In the testcase, the block with overflow!=visible is large; on http://planet.gnome.org/ the block with overflow!=visible is not large, but the page is.
The attached testcase shows me the behavior described in comment 0. It may be HW related, I'll check it on some other configurations.
Probably a 16-bit widget coordinates bug. Should be fixed on trunk now that compositor phase 1 has landed.
Depends on: 215055
Flags: blocking1.9.2? → wanted1.9.2+
If it's not fixed please reopen.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

25 days ago
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.