Closed Bug 470443 Opened 12 years ago Closed 10 years ago

[N810 no-swap] Lose ability to close tabs when you run out of memory

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Maemo
defect
Not set

Tracking

(fennec1.0-)

RESOLVED WONTFIX
Tracking Status
fennec 1.0- ---

People

(Reporter: cmtalbert, Unassigned)

References

Details

(Keywords: qawanted)

This may be a moot issue if we improve the memory management infrastructure.  However, on memory constrained devices like these, I think we always have to have a "plan B" in case we get into a thrashing state.

Here's what happened.
1. Open four tabs: about:config Bugzilla.mozilla.org, cnn.com, nytimes.com
2. Use those sites for a bit to build some memory usage
3. Open another tab with gmail in it.
4. Log into gmail
5. Start getting out of memory errors, specifically a dialog box that says "A script on this page has been stopped due to low memory"
6. Open the tab bar so that you can kill off an old tab to free some memory.

= Actual =
You can get the tab open, but since we are in dire memory straits, we aren't drawing the tab previews.  Since there are no tab previews there are no "X" buttons to close the tabs.  You can't close any of the old tabs.  The only way out is to kill the application.

= Expected =
We provide some means for the user to attempt to correct this state by doing the most obvious thing: blowing away old tabs.  However, it's my preference that we architect so that we are very rarely in this state to begin with.

Version: Mozilla/5.0 (X11; U; Linux armv6l; en-US;rv:1.9.2a1pre) Gecko/20081219 Fennec/1.0a2pre
this is an old bug, but pretty serious.  I know we have a lot of issues when we run out of memory.  I ran into a similar issue to this on winmo today when I ran out of memory and ended up re-seating the battery.
tracking-fennec: --- → ?
Flags: wanted-fennec1.0?
 Iam having a hard time reproducing this.  I have swap on and had this list +1 more site loaded...all worked just fine and I could open a new tab or close existing ones.
This is still happening to me on build (without swap):

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.2a2pre) Gecko/20090903
Fennec/1.0b4pre


...using tabs for the following sites:
www.google.com
mail.yahoo.com
https://www.verisigin.com/
quality.mozilla.org/docs
sports.yahoo.com/mlb/scoreboard
www.google.com/news
tracking-fennec: ? → 1.0-
Flags: wanted-fennec1.0?
Keywords: qawanted
We haven't seen this on the n900, so I believe this is a n810 no swap issue.
Summary: Lose ability to close tabs when you run out of memory → [N810 no-swap] Lose ability to close tabs when you run out of memory
N810 is no longer a target
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.