Closed Bug 470518 Opened 13 years ago Closed 13 years ago

Allow the wav audio player to play GSM/MSGSM Wav format

Categories

(Core :: Audio/Video, defect)

x86
Linux
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 475110

People

(Reporter: mp3geek, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20081218 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20081218 Minefield/3.2a1pre

Brings up the audio player, but unable to play

Reproducible: Always

Steps to Reproduce:
1. open gsm-wav file
2. no sound, no play
3.
Actual Results:  
No sound from audio player

Expected Results:  
Sound! :)
Attached audio GSM-WAV sample
For more information about GSM/WAV,

http://kbs.cs.tu-berlin.de/~jutta/toast.html
For the case where you're trying to play a standalone Wave file of this format, now that bug 475110 is fixed, we will fall back to whatever plugins are registered for Wave handling.

For the HTML5 <video>/<audio> elements, the spec requires support for PCM and I don't see any reason to support additional formats.  The link you supplied suggests that this particular format may be subject to patent claims, which makes it a particularly unappealing format to support--a patent investigation would need to be conducted, and in likely-seeming case where a patent license is required, it would not be possible for us to implement it.

For compressed audio in the HTML 5 media elements, I recommend using our existing support for Vorbis.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Resolution: --- → WONTFIX
basically we have an asterisk phone setup, where missed calls saved as the .wav-gsm encoded file (default format?), does the patent claims extend to Asterisk as it is with firefox?
I don't know--I don't even know if such patents exist, and I'm definitely not qualified to give any kind of advice about such issues.  I was pointing out that your link suggests that there is some question of possible patent coverage for that algorithm, which is something that could further complicate/impede an implementation within Gecko (beyond the problem of additional formats not being part of HTML 5's media spec, and thus having to worry about cross-browser support and compatibility).

As I mentioned, now that bug 475110 is fixed, the behaviour for handling Wave files is exactly the same as it was in Firefox 3.  That is, if your system supplied a handler to play the file when loaded as a standalone document in the browser, it will continue to work as it used to.  The new <video>/<audio> elements added in Firefox 3.5 will only support PCM Wave files because that functionality uses our internal Wave audio support.
Attachment #353936 - Attachment mime type: application/octet-stream → audio/wav
Correct. It works for me as expected. The plugin takes the wav file and plays it. That makes it a dupe of bug 475110.
Status: RESOLVED → VERIFIED
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 475110
You need to log in before you can comment on or make changes to this bug.