Annoyance: Anchor link jump of doom.

RESOLVED DUPLICATE of bug 103279

Status

()

--
minor
RESOLVED DUPLICATE of bug 103279
10 years ago
10 years ago

People

(Reporter: edwardsgreg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

Whenever following a link containing an anchor to a page long enough to scroll, if you begin scrolling the page, the browser will jump you back to the location of the anchor once the page has finished loading.

This can become extremely annoying if the page is taking a long time to load, say, some images, but you have already moved on away from the anchor only to get snapped back at an unpredictable moment.

Ideally, if you start scrolling a page from an anchor link, this jumpback effect should be disabled, and it should behave as if there is no anchor in the URL. The act of scrolling on the part of the user indicates that he is no longer (or never was) interested in the anchor contained in the link.

Message boards are notorious for causing this.

Reproducible: Always

Steps to Reproduce:
1. Follow a link with a valid anchor in the URL to a page you know will take more than a few seconds to load.
2. Scroll the page before loading is complete.
Actual Results:  
The scroll position will jump spontaneously to another spot in the document.

Expected Results:  
No scrolling jump should occur.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 103279
You need to log in before you can comment on or make changes to this bug.