"link" link for domain non-functional on "Top Crashers by Domain" report

RESOLVED FIXED in 1.1

Status

RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: alqahira, Assigned: ozten)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: next, URL)

Attachments

(1 attachment)

If you load a "bydomain" report, the "link" link adjacent to the domain (as opposed to the "link" next to a particular page) is non-functional; it produces a link to the crash-stats page with the domain post-pended, e.g. for www.facebook.com, the "link" points to http://crash-stats.mozilla.com/topcrasher/bydomain/Firefox/www.facebook.com

Either the "link" link needs to be disabled for domains, or it needs to point to the domain.

On the other hand, generally having both the site/page *appear* to be a link (it's really just an additional expand/collapse widget like the +/-) and then having a second "link" link that is the real link to the site is a little confusing.  

I think ideally I'd prefer either a) the site/page link to the actual site and have no extra "link" link, or b) have the site/page not be a link at all (it could still be an additional expand/collapse widget as long as it didn't look like an actual link) and the "link" link be the link to the actual website.

(If we were to keep the "link" link, perhaps it should be renamed "visit page" or something.)
(In reply to comment #0)
> On the other hand, generally having both the site/page *appear* to be a link
> (it's really just an additional expand/collapse widget like the +/-) and then
> having a second "link" link that is the real link to the site is a little
> confusing.  

This is going to get old for QA pretty quickly, I think.  When filing bug 470527, I kept trying to do Copy Link Location on the URL rather than on the "link", because it looks like a link and looks like the URL I want to copy....

I'm happy to spin the "what's a link and what isn't" part of this bug off into a new one, separate from the bad "link" links for domains, if you'd like.
Depends on: 411358
See also bug 470563 from timeless about the "link" link.

Updated

10 years ago
Duplicate of this bug: 470563
(Assignee)

Comment 4

10 years ago
I read 470563, but am confused.

How about this.

- domain
  + url #
  - url #
    Signature - User Comment
Here the +/- widget, domain, and url links still do expand contract.
The # opens the url in a new window. domain does not have a '#'.
User Comment is a link to the crash report.

# is sometimes used as text for the "permalink" of a post in blogging. It is a stand-in until we get a graphic design for a "open this link in a new window" image.
Status: NEW → ASSIGNED
Austin, while we try to find the correct linkification here we should have a look at bug 470561 in parallel. Without JS the page isn't accessible. So I would propose the following:

domain or +/- should be linked too. If JS is disabled the list of URL's should be collapsed/expanded. That means we have to reload the page with changed parameters.

# should be changed to e.g. 'open' or 'open link'

By linking the comments it's hard to follow one comment. Especially when it is wrapped. Could you also use a table oriented layout instead of dots? Probably with a different background for odd/even rows? In that way we can only highlight the currently hovered comment instead of all comments under the signature.

Just my 2c.
The setup that's active now (comment 4) is better.  

However, I have a philosophical dislike for sites making links open new windows, though; it's disruptive, and it shows that the site author presumes to know more about my workflow than I do.

I'd like to expand upon Henrik's comment about the "#", though; it's not going to be universally understood, and I'm not sure an image is the way to go, either, as it may be difficult to get an image that's universally understandable.  I'd prefer some text (being localizable, text is good for universal understanding), probably something like "open URL" or "view site".

I still think that having the "www.google.com" and "www.google.com/firefox" stuff look like regular links is confusing, though maybe changing the "#" for some descriptive text would help.
(Assignee)

Comment 7

10 years ago
Okay, links will not open in a new window automatically.
Whiteboard: next
Austin - is this fixed?
Assignee: nobody → ozten.bugs
Target Milestone: --- → 1.1
(Assignee)

Comment 9

9 years ago
Created attachment 411419 [details] [diff] [review]
First attempt Fixes for url format and linking signatures

Wraps urls in a span so that we can have Copy in the link.
Adds "Expand" in front of domain or url which expands the list.
Changes # into "Open This URL" for offsite link.
Linkifies Crash signatures to the crash reports by signature listing page.
Attachment #411419 - Flags: review?(ryan)
Attachment #411419 - Flags: review?(ryan) → review+
Comment on attachment 411419 [details] [diff] [review]
First attempt Fixes for url format and linking signatures

Looks good!  Ajax calls worked as directed...
(Assignee)

Comment 11

9 years ago
Committed r1441.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.