Closed Bug 470538 Opened 11 years ago Closed 11 years ago

Setting HTTPS login: to Allow from Required has no effect

Categories

(support.mozilla.org :: Knowledge Base Software, task)

task
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: nkoth, Unassigned)

Details

It does not seem to be able to disable the requirement for https on SUMO production.

Setting it here seems to have no effect: https://support.mozilla.com/tiki-admin.php?page=login

It works on staging though. Tried clearing all the caches etc... but no effect. See https://bugzilla.mozilla.org/show_bug.cgi?id=470517#c3
Could this be working now, and perhaps due to bug 470546? If so, see bug 470550 for possible root cause.
It might be useful information to see on the slave db:

select * from tiki_preferences where name='https_login';

The setting for https is "required" (current setting). After changing in the admin panel, it should change to "allowed", in which case the redirect should not go to the https login, but http login. (redirect code is at the top of tiki-login.php)
This is probably just memcache, I'd suggest.
Can we set sometime to troubleshoot this and resolve this once and for all?
Assignee: nobody → nelson
Target Milestone: 0.9 → 0.8.1
When is the next maintenance window? We should arrange to figure this out then.

(In reply to comment #4)
> Can we set sometime to troubleshoot this and resolve this once and for all?
Will test in the 0.8.1 push window, pushing any further work out to 0.8.2.
Target Milestone: 0.8.1 → 0.8.2
Target Milestone: 0.8.2 → 0.9
Assignee: nelson → nobody
Target Milestone: 0.9 → Future
This is irrelevant now - WONTFIX
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.