Last Comment Bug 470542 - SVG image partially cut off due to some filter
: SVG image partially cut off due to some filter
Status: RESOLVED DUPLICATE of bug 467930
: regression, testcase
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-20 03:29 PST by Thomas Goldstein
Modified: 2008-12-26 13:30 PST (History)
3 users (show)
roc: blocking1.9.1-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Image with shadow filter applied, cut on the left (4.59 KB, image/svg+xml)
2008-12-20 03:30 PST, Thomas Goldstein
no flags Details
Same image with shadow filter disabled (4.57 KB, image/svg+xml)
2008-12-20 03:31 PST, Thomas Goldstein
no flags Details

Description Thomas Goldstein 2008-12-20 03:29:20 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081219 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081219 Shiretoko/3.1b3pre

I'm on the Shiretoko branch, and see this problem: the left of my image is cut off (testcase coming up in following post). If I take off the filter, the left of the image reappears.
This doesn't happen in other browsers.

Reproducible: Always
Comment 1 Thomas Goldstein 2008-12-20 03:30:51 PST
Created attachment 353957 [details]
Image with shadow filter applied, cut on the left
Comment 2 Thomas Goldstein 2008-12-20 03:31:13 PST
Created attachment 353958 [details]
Same image with shadow filter disabled
Comment 3 Thomas Goldstein 2008-12-20 03:51:13 PST
This is a regression, the image is not cut off with Firefox 3.0.x.
Comment 4 Steve England [:stevee] 2008-12-20 04:02:02 PST
Confirming this is a regression.

With Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6pre) Gecko/2008121905 GranParadiso/3.0.6pre the side is not cut in either example.

With Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081219 Shiretoko/3.1b3pre ID:20081219080733 there is a cut on the left hand side of the svg image that has the filter applied.
Comment 5 Thomas Goldstein 2008-12-20 04:05:27 PST
I just noticed the top is also cut off with Shiretoko, not just the left. I missed that.

This might only affect the border of an object, and not the inside, I'm not sure. That's what happens with the testcase, at least (disable the object border, and nothing is cut), but that could be due to particular filter settings. I'm not sure.
Comment 6 Steve England [:stevee] 2008-12-20 04:49:31 PST
No cuts at the top or the left hand side:
- Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008071303 Minefield/3.1a1pre

Cuts at the top and the left hand side:
- Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008071403 Minefield/3.1a1pre

Changes pushed after 2008-07-13 02:00:00, before 2008-07-14 04:00:00
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-07-13+02&enddate=2008-07-14+04

Bug 416305 perhaps? CC'ng roc
Comment 7 Steve England [:stevee] 2008-12-20 04:50:35 PST
Note that with the 2008071403 build the shadow has also disappeared, but it reappears with the next build (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008071504 Minefield/3.1a1pre) but the top and side is still cut.
Comment 8 Robert Longson 2008-12-20 07:01:17 PST
We don't account for stroke-width contributing to the underlying object size.

*** This bug has been marked as a duplicate of bug 467930 ***

Note You need to log in before you can comment on or make changes to this bug.