If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

update button on twitter no longer works (since 2008-12-19, affecting as far back as beta 1)

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: beltzner, Unassigned)

Tracking

Details

(URL)

Build: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20081220 Firefox/3.1b3pre

STR:
1. Go to twitter.com/home (you'll need a twitter account)
2. Type a status update
3. Click "update"

Expected: your twitter status updates
Actual: request seems to send, but nothing happens

There are a few warnings in the error console, but nothing seems relevant. I believe that this was working properly in the 12/18 nightly (there is no 12/19 OSX nightly) but definitely not working in the 12/20 nightly.

A tracemonkey merge came in between those builds, and this is a javascripty thing, so I suspect it might be due to that. cc'ing robcee and mossop who are also seeing it.
Flags: blocking1.9.1?
I tried this in FF3.1Bb2 and I couldn't post from that version either.
Twitter update that broke it maybe then?
Very possible.  I wish firebug was working here.
http://antennasoft.net/robcee/2008/12/17/firebug-in-firefox-31b2-and-beyond/
Summary: update button on twitter no longer works (after 2008-12-19 tracemonkey merge) → update button on twitter no longer works (after 2008-12-19 tracemonkey merge?)
The fancy scripty version is trying to send updates to s.twitter.com which is NXDOMAIN everywhere I've tried to resolve it, so it definitely looks like a twitter issue.
Just confirmed that the "update" button no longer works on Firefox 3.1 Beta 2 nor Beta 1, so my suspicion of this being due to the most recent tracemonkey merge seems imprudent.

The update button *does* still work in Firefox 3.0.x, though. I'm adding some more people and moving to Core::General since it's not clear to me that this isn't potentially due to some of the new content restriction stuff we've been working on since early betas. It would be nice to get a regression window, in terms of at what point between Firefox 3 and 3.1 builds this stops working so we know where to look.
Assignee: general → nobody
Component: JavaScript Engine → General
Keywords: regressionwindow-wanted
QA Contact: general → general
Summary: update button on twitter no longer works (after 2008-12-19 tracemonkey merge?) → update button on twitter no longer works (since 2008-12-19, affecting as far back as beta 1)
Duplicate of this bug: 470643
Flags: blocking1.9.1? → blocking1.9.1+
from Ryan Flint:

http://getsatisfaction.com/twitter/topics/why_wont_twitter_let_me_post_new_updates_anymore

http://getsatisfaction.com/twitter/topics/opera_suddenly_doesnt_work

Looks like this might just be a twitter.com issue, though I don't know why it is that I can get Firefox 3 to work reliably.

Comment 9

9 years ago
This regressed between 20080930050845 - http://hg.mozilla.org/mozilla-central/rev/86b982e8b73e and 20081001 - http://hg.mozilla.org/mozilla-central/rev/63b0791327ab
Keywords: regressionwindow-wanted
That's a range of:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=86b982e8b73e&tochange=63b0791327ab
Within that range are:
 - tracemonkey merge
 - xmlhttprequest access control work

both of which feel like potential good places to start. Though, Ryan's links and comment 5 indicate it could be some combination thereof plus a bad reaction to the s.twitter.com bit.
Ryan: How is twitter trying to send data to s.twitter.com? Using XHR, <script src="http://s.twitter.com/..."> or something else?

The only thing that the Access-Control patches *should* have affected is if a script tries to do XHR.open("cross domain URI"). Such a command used to throw, but now doesn't.

It's seems unlikely that twitter would be relying on that, although it is of course possible.
It's an XHR in http://assets3.twitter.com/javascripts/application.js using jQuery from http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js. I just tested this in 3.0.x and the XHR fails with a security error and it falls back to doing a normal form POST to twitter.com/status/update - which is why it's working there. In 3.1 we're allowing the XHR to happen which fails because s.twitter.com doesn't exist and at that point the form action's been overridden so there's no fallback.
Ugh, not much we can do other than evangelize then :(
Assignee: nobody → english-us
Component: General → English US
Flags: blocking1.9.1+
Product: Core → Tech Evangelism
QA Contact: general → english-us
Target Milestone: mozilla1.9.1b3 → ---
Version: 1.9.1 Branch → unspecified
Depends on: 470752
--> Tech Evangelism: usual suspects, do we have any contacts at Twitter?

Ryan: got a URL/reference to the ticket you filed?
Assignee: english-us → arabic
Component: English US → Arabic
QA Contact: english-us → arabic
Assignee: arabic → english-us
Component: Arabic → English US
QA Contact: arabic → english-us
I have one - let me see what I can do.
I mailed Alex Payne @ Twitter.  He works on backend stuff, but probably knows someone on the front end team.  Hoping that he's reading work mail today.
can I suggest to also message @twitter directly on twitter ?
Duh, yeah, thanks Daniel.  I'll do that.
(In reply to comment #15)
> Ryan: got a URL/reference to the ticket you filed?
#348414 filed Saturday evening. I just poked it again to see if I can get someone to respond. Cooked up http://twitter.com/rflint/status/1071766890 as an easy workaround in the meantime.

Comment 21

9 years ago
They're now aware: http://status.twitter.com/post/66263547/unable-to-post
Seems like it's fixed now.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Yay!! Thanks guys, that rocks!
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.