Incorrect display of some devanagari (U900) character sequences on mac

RESOLVED DUPLICATE of bug 428317

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 428317
11 years ago
11 years ago

People

(Reporter: alok, Unassigned)

Tracking

({intl})

3.0 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; hi-IN; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; hi-IN; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

Firefox 3.05 on mac os x does not display some devanagari (U900) character sequences properly.
They are displayed properly on Safari.
At the URL http://devanaagarii.net/de-sample-mac-safari-firefox.html there is a list of words written in devanagari script. word # 4,5,6,7,8, 16 and 22 are not displayed properly. The correct display can be seen in Safari, or in the juxtaposed screenshot at http://devanaagarii.net/chhavi/de-sample-mac-safari-firefox.png - Safari rendering on the left and firefox on the right.

If you do not see the page as displayed in the screenshot, please see the instructions at http://devanaagarii.net/mac for setup instructions.

Reproducible: Always

Steps to Reproduce:
1. Go to the url http://devanaagarii.net/de-sample-mac-safari-firefox.html
Actual Results:  
The display should have been the same as in Safari

Expected Results:  
Some words were not displayed correctly.

This makes the browser unusable for users of devanagari (Hindi, Marathi, Nepali and Sanskrit languages) unusable on the mac.
Reporter

Updated

11 years ago
Component: Help Documentation → General
Keywords: intl
Version: unspecified → 3.0 Branch
Reporter

Comment 1

11 years ago
Posted file test case
Test case
Reporter

Comment 2

11 years ago
On the left is the correct rendering in Safari and the right is the incorrect rendering in firefox.

Updated

11 years ago
QA Contact: help.documentation → general
This works fine in Firefox 3.1b2, I think. Firefox 3.0.x (Gecko 1.9.0.x) has some issues there.
Reporter

Comment 4

11 years ago
Tested by me, the original reporter on firefox 3.1b2 after comment #3 and this bug isn't there in that version. Please do whatever's needed to be done for bugs present in 3.05 and fixed in 3.1b2 for this bug.
Thanks for confirming this. That enabled me to find that the issue got fixed on trunk / Gecko 1.9.1 branch between 20081106 and 20081107:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f3993df71c29&tochange=18fec592b35b
which leads to bug 428317.
(there is a chance that this will get fixed for Gecko 1.9.0.6/Firefox 3.0.6)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 428317
You need to log in before you can comment on or make changes to this bug.