Firefox 3.0.5 always starts in Offline Mode although connected to network

RESOLVED DUPLICATE of bug 424626

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 424626
10 years ago
10 years ago

People

(Reporter: John Ståhle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121621 Ubuntu/8.04 (hardy) Firefox/3.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121621 Ubuntu/8.04 (hardy) Firefox/3.0.5

Even though I can see, that I am connected to the network (e.g. System Monitor shows traffic, Thunderbird shows "downloading x messages of y) Firefox 3.0.5 *always* starts in Offline Mode. This Also in happened in 3.0.4.

It makes no difference whether 
1. tabs were open with webpages when I last quit Ff
2. I start a fresh session
3. the session is started by Thunderbird.

Unchecking Work Offline only works for the present session, at next start I have to uncheck 'Work Offline' again and initiate a reload for each page.



Reproducible: Always

Steps to Reproduce:
1. Start Firefox

Actual Results:  
'Work Offline' is checked.

Expected Results:  
'Work Offline' unchecked.

I am connected to a GPRS (cell phone) network through a HUAWEI dongle to a visible BTS (on top of the nearest mountain) some 600 m (1,800 feet) away, but *e.g.* thunderbird has no problems detecting that the connection is open.

There is a workaround, but it is very annoying to be forced to waste time *every* time Ff is started - imagine 15 open tabs and each has to be restarted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424626
You need to log in before you can comment on or make changes to this bug.