Closed Bug 470808 Opened 12 years ago Closed 12 years ago

crash [@ nsProxyEventObject::CallMethod(unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*)]

Categories

(MailNews Core :: Networking: IMAP, defect)

x86
Windows Vista
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 476960

People

(Reporter: wsmwk, Unassigned)

Details

(Keywords: crash, topcrash)

Crash Data

topcrash for 3.0b1

crash [@ nsProxyEventObject::CallMethod(unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*)]


oldest build crashed I can find is 3.0b1pre 20081127032637 bp-b41099c1-34c0-4f96-9b05-d93ff2081128

Signature [Expand]	Source
nsProxyEventObject::CallMethod	xpcom/proxy/src/nsProxyEventObject.cpp:257
PrepareAndDispatch	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
SharedStub	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
nsImapProtocol::TellThreadToDie	nsImapProtocol.cpp:1181
Component: General → Networking: IMAP
Product: Thunderbird → Core
QA Contact: general → networking.imap
comments from bp-3e551696-bb5d-4625-aa14-e44f32090114

was deleting email from an IMAP account (Dovecot IMAP) when it crashed (using the delete key on the keyboard)
Product: Core → MailNews Core
I expect this to also become a topcrasher for 3.0b2.
(no comments in any of the crashes)
Severity: normal → critical
Flags: wanted-thunderbird3?
(In reply to comment #2)
> I expect this to also become a topcrasher for 3.0b2.
> (no comments in any of the crashes)

This crash has in fact not appeared in 3.0b2.
3.0b2pre had a few crashes in last 21 days, such as:
- 20090210084045 bp-27984ab9-105f-49f6-9a01-169522090302, and
- 20090213031214 bp-e21798e6-affb-4770-b914-dbf552090216

the last one is 20090213031214, which is just before 20090217 checkin of Bug 476960 - IMAP Hang involving UI thread. With no crashes since then, this appears to have been fixed by bug 476960 

slight variation of stack on crash-stats is also gone - @0x0 | nsProxyEventObject::CallMethod(unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*)
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476960
Flags: wanted-thunderbird3?
Crash Signature: [@ nsProxyEventObject::CallMethod(unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*)]
You need to log in before you can comment on or make changes to this bug.