Closed Bug 470883 Opened 11 years ago Closed 11 years ago

Moving Tab to New Window (Ctrl+Alt+T) restarts flash apps and videos

Categories

(Firefox :: Tabbed Browser, enhancement)

3.5 Branch
x86
Windows Vista
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 449734

People

(Reporter: shiften, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

When I move a tab to a new window, the content of that window should behave as if nothing happened.  Flash videos should continue on as before.

A way to do this would be to decouple the page layout/rendering from the actual display of the tab or window or whatever.

Reproducible: Always

Steps to Reproduce:
1. Open a web page with a flash video with more than one tab open.
2. Start the video playing
3. Right click on the opened page and select "Move to New Window" or press Ctrl+Alt+T.

Actual Results:  
See that the moved tab stops the video because flash thinks it's a newly loaded page.

Expected Results:  
I would expect the flash video to continue playing as if nothing happened.  (we aren't really supposed to be making a new/duplicate page)

Display in a tab/window should be not be referenced to the actual window it's in and instead be movable from window to window.
Blocks: 225680
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 3.1 Branch
Ctrl+Alt+T is an extension provided shortcut, as is "Move to New Window". Assuming that that extension uses the same back-end code as "Open in a New Window"...
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449734
You need to log in before you can comment on or make changes to this bug.