Control-Tab and Control-Shift-Tab don't cycle through the Tab History List

RESOLVED DUPLICATE of bug 395980

Status

()

defect
RESOLVED DUPLICATE of bug 395980
11 years ago
11 years ago

People

(Reporter: u318697, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

It's normal on MDIs, at least in Windows, that Control Tab and Control Shift Tab cycle through the document history list, that is the list of how recently documents have been accessed, not some other list such as the order in which documents were created or loaded.  I believe some refer to the history list as the Z-order.

So, for example, a typical way of working in a Windows MDI such as the excellent editor Textpad is ...
	Edit some document that I shall call #1
	Cycle through the tabs using Control- or Control-Shift-Tab to, say, #2
	Edit #2 for a while
	Control-Tab now takes you back to the most recently accessed doc, ie #1
	Edit #1 some more
	Control-Tab now takes you back to the most recently accessed doc, ie #2
	Edit #2 some more
... etc.

But, infuriatingly, this doesn't work in FF.  Instead it cycles through all the other tabs to get back to where you were (which is what Control-Page-Up and Down are supposed to do, and indeed do, so why make Control-Tab duplicate this functionality at the expense of its own?).


Reproducible: Always

Steps to Reproduce:
1. Create at least 3, preferably 5 or more tabs.
2. Use Control-Tab to change tabs
3. Use Control-Tab to change tabs again
Actual Results:  
The second use of Control-Tab performs the same function as Contol-Page-Down and takes you to the third tab.

Expected Results:  
The second use of Control-Tab should return you to the first tab, as that was the most recently accessed.

AFAIAA, all versions of FF have suffered from this bug.  It renders the keystroke shortcuts Control Tab and Control Shift Tab useless, whereas in a normal Windows environment they are very useful indeed.
you may be interested in bug 465076, that will introduce this behavior.
OS: Windows 2000 → All
Hardware: x86 → All
Depends on: 465076
Reporter

Comment 2

11 years ago
I'm very much afraid that rather than simply introduce this behaviour, it will introduce a whole new behaviour when Control-Tab is pressed, and thereby ensure that the original Windows behaviour is never introduced.  Frankly, that's the last thing I want, it would be even more irritating than ending up on the wrong tab as with the current behaviour.

Please see my comments in that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395980

Comment 4

11 years ago
(In reply to comment #0)
> It's normal on MDIs, at least in Windows, that Control Tab and Control Shift
> Tab cycle through the document history list, that is the list of how recently
> documents have been accessed, not some other list such as the order in which
> documents were created or loaded.

This premise of yours is actually wrong. For traditional MDI application Ctrl+Tab and Ctrl+PageUp behave the same. I could make the exact opposite point by citing an older version of Adobe Reader (MDI mode was removed in version 9) or Microsoft Excel (at least up to version 2003).

Then again, Firefox isn't an MDI application at all, but rather a hybrid (sometimes called TDI) for which there is no "original Windows behavior" at all.
You need to log in before you can comment on or make changes to this bug.