[BLOCK] Sidebar collapses if you resize the window

VERIFIED FIXED in M7

Status

P1
blocker
VERIFIED FIXED
20 years ago
14 years ago

People

(Reporter: sfraser_bugs, Assigned: pollmann)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
In apprunner, expand the sidebar, and click on an item to load it. Now resize
the window. The sidebar collapses back to its original size. The sidebar should
stay open, and only change size when the window is so narrow that some
adjustment is necessary.

Updated

20 years ago
Component: Apprunner → XPApps
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Target Milestone: M4

Comment 1

20 years ago
Re-assigned to matt@netscape.com, set target milestone to M4, changed component
to XPApps, and platform and OS to All.

Matt, is this fixable for M4 by Friday?

Updated

20 years ago
Assignee: don → matt
Priority: P3 → P1
Target Milestone: M4 → M5

Comment 2

20 years ago
Changed target milestone to M5.

Comment 3

20 years ago
This is actaully a frames bug
In viewer.exe
goto http://warp
move  the frame border all the way to the right
resize the browser
Frameboarder was go back to it's orignal place

Updated

20 years ago
QA Contact: 3853 → 4078

Updated

20 years ago
Assignee: matt → pollmann

Comment 4

20 years ago
This is a frames bug in gecko.
I think this is erics.
(Assignee)

Updated

20 years ago
Target Milestone: M5 → M6
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

20 years ago
I've got a fix for this in my tree, will be checking it in soon.
(Assignee)

Comment 6

20 years ago
*** Bug 6715 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

20 years ago
Target Milestone: M6 → M7
(Assignee)

Comment 7

20 years ago
This isn't critical for M6, marking M7.

Updated

20 years ago
Severity: normal → blocker
Summary: Sidebar collapses if you resize the window → [BLOCK] Sidebar collapses if you resize the window

Comment 8

20 years ago
Upgrading this to a blocker bug.

Updated

20 years ago
Assignee: pollmann → karnaze
Status: ASSIGNED → NEW
(Assignee)

Updated

20 years ago
Assignee: karnaze → pollmann
(Assignee)

Comment 9

20 years ago
I've got a fix for this 'un.  :)  Chris, I'm using the new user-dragged sizes to
recalculate the Row/ColSpecs array, like we discussed before.

The only minor problem with this solution is that percentage-based widths are
going to be accurate to within only 1% of the browser window width because the
RowSpec stores an integer.  If we can change this to store the spec in floats,
it can be accurate to within a pixel, which is what I think we want.
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

20 years ago
Just checked in a fix.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 11

19 years ago
verified in 6/14 builds
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.