dialog doesn't paint if you have larry open (or something like this)

VERIFIED FIXED

Status

VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: timeless, Assigned: mfinkle)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows XP

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081222 Fennec/1.0a2

i've been able to trigger this repeatedly, but i'm having trouble w/ precise steps.

0. fresh profile
1. load http://www.google.com
2. load https://www.citizensbank.com/
3. immediately after you hit <enter>, click the favicon in the url field
-if you get a security warning dialog with no content, stop here-
4. dismiss the dialog
5. click the url field
6. press enter
7. immediately after you hit <enter>, click the favicon in the url field

expected results:
a. Larry stays visible
b. some useless dialog (with content)

actual results:
a- Larry disappears
b- Security Warning dialog with no content
(Reporter)

Comment 1

10 years ago
Created attachment 354458 [details]
picture
I have confirmed this bug with the beta1 builds.

I do this:
1) launch fennec (either in maemo or linux desktop)
2) browse to http://m.facebook.com/?w2m  <- note this is the default page for www.facebook.com on the maemo device
3) enter my email address: joel.maher@gmail.com
4) hit the enter button or tap the log in button
5) you are redirected to a new page:
   https://login.facebook.com/login.php?m=&next=http%3A%2F%2fm.facebook.com%2Fhome.php%3Fla1daac65
 - on this page you get a security warning which is blank.  On maemo, there is no 'X' or method to cancel this dialog.  Actually you cannot even kill the fennec process from the list of running apps (I have to killall fennec from a ssh session).  On linux desktop there is a X to close the blank security warning dialog.

This is very similar to this reported bug and exhibits a difficult situation on the maemo device.
Status: UNCONFIRMED → NEW
Ever confirmed: true
as a side note, other dialogs that we display are:
Warning: unresponsive script <- gmail/slashdot to repro
Resend: cancel/resend <- fill out a form, browse to another page, hit the back button
(Reporter)

Updated

10 years ago
tracking-fennec: --- → ?
tracking-fennec: ? → 1.0b2+

Updated

10 years ago
tracking-fennec: 1.0b2+ → 1.0b3+

Updated

9 years ago
Assignee: nobody → mark.finkle
Sounds like this should be changed by the prompt dialog patch (bug 489423)
Interestingly, this works for me on build:

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20090827
Fennec/1.0b4pre
Joel or Al, can I get a confirmation this is working for you guys too?
I was not able to reproduce this bug with my n810 and beta3.  timeless, can you verify and mark as resolved/wfm?
resolving. reopen if it comes back
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
still not able to reproduce this.  Seems to be fixed.

Verified on n810 with 1.9.2 nightly build 20090921
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.