Closed Bug 471329 Opened 11 years ago Closed 11 years ago

Dutch Holidays 2006-2011

Categories

(Calendar :: Website, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: pander, Assigned: bvdbos)

References

()

Details

Attachments

(1 file, 1 obsolete file)

15.83 KB, application/octet-stream
Details
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5
Build Identifier: 

Please update this file:
  http://www.mozilla.org/projects/calendar/caldata/DutchHolidays.ics
which is presented here:
  http://www.mozilla.org/projects/calendar/holidays.html
with the following information from:
  http://nl.wikipedia.org/wiki/Feest-_en_gedenkdagen

Update the calender to (including) 2015 and make the following changes.

Label the following days with category "Public Holiday":
* 30 april - Koninginnedag
* 5 mei - Bevrijdingsdag (this category only every 5 year, 2010, 2015, et cetera but leave this without category in other years)
* 1 januari - Nieuwjaarsdag
* Variabel - Goede Vrijdag
* Variabel - Paasmaandag
* Variabel - Hemelvaartsdag
* Variabel - Eerste en tweede Pinksterdag
* 25 en 26 december - Eerste en tweede Kerstdag

Rename Wereld-dierendag to Werelddierendag or simply Dierendag.

Add the following days (without catergory):
* Variabel - Carnaval
    * 22 februari 2009 t/m 24 februari 2009
    * 14 februari 2010 t/m 16 februari 2010
    * 6 maart 2011 t/m 8 maart 2011
    * 19 februari 2012 t/m 21 februari 2012
    * 10 februari 2013 t/m 12 februari 2013
    * 2 maart 2014 t/m 4 maart 2014
    * 15 februari 2015 t/m 17 februari 2015
    and possibly Aswoensdag the day after Carnaval:
        * 2009 : 25 februari
        * 2010 : 17 februari et cetera
* 1 mei - Dag van de arbeid
* 24 augustus - Naturalisatiedag
* 3e dinsdag in september - Prinsjesdag
* 5 december - Pakjesavond
* 6 december - Sinterklaasfeest
* 15 december - Koninkrijksdag

Carnaval is mostly celebrated below the big rivers, however, it is good to know when and when not to plan a business meeting in Maastricht ;)

As the Dutch goverment decided this year, Suikerfeest, is not to be added yet. Let this be a criteria for including this day in this calendar or not to avoid enless discussions.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Please assign this to Dutch Localization Bugs
Possibly also add:
* http://nl.wikipedia.org/wiki/Sint_Maarten_(feest) (also 11th of the 11th which effects St Maarten)
* http://nl.wikipedia.org/wiki/Driekoningen

But not to make this into a religious calendar, more that people know something nationally/traditionally is going on that effects business times or working hours. It will raise consciousness for all about what is going on in the Netherlands.
Please supply a valid iCalendar file (*.ics) with your suggested data. The project team doesn't compile those files but takes them from volunteers who want to contribute to the collection of holiday calendar files.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Component: General → Website
QA Contact: general → website
Resolution: --- → INCOMPLETE
I hope the original compilers of the Dutch holidays could have a look at my proposition to say whether all is OK. I don't know their email addresses, hence my request to Dutch Localization Bugs team. If they are Ok with it, I'm willing to provide an updated file.

For the implementation of Bevrijdingsdag, a combination of 5 5-yearly events will have to be used.
Resolution: INCOMPLETE → FIXED
As for the labeling of category's: there's people who use the English version and people who use the dutch version of Lightning. There's localized versions of category's now. We'll have to look into this before we apply categories. 

Without turning this into the political discussion we saw at many places already, I think suikerfeest should be added. I'm also inclined to add driekoningen and perhaps St. Maarten but to be honest, these are, as you say, religious days. I't's good to add an url to the wikipages in these. 

Valid suggestions and reopening this bug. Martin, you were to soon closing :-)
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Assignee: nobody → bvdbos
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Thanks for following up on this.

Sunbird is an office application to be used in businesses, organisations and schools but also privately. I would use the following as a reference for including days in the holiday calendar:

   All days which effect office hours (total closure or most people leaving early) and infrastructure for the entire country or large parts of it, be it national holidays or religious days. The goal is to make people aware about the risk of planning events on those days, whether a part of the country or the entire country (in terms of people and common or public services) are probably not available as usual.

Bas, is this a sound definition of also the way you see it?

As for the categories, indeed, people can rename or localise categories. Sunbird should also support category numbers which are automatically mapped to the localised translation. I'll make a separate and independent bug report for this.
See also https://bugzilla.mozilla.org/show_bug.cgi?id=471386 regarding language independent categories.
Guys, just to be clear on this. Martin's resolution was right, as we don't prepare the holiday calendars by ourselves. I won't close this one for now, as I take it that Bas is doing the work here, given that he assigned the bug to himself.
Version: unspecified → Trunk
Attached file Dutch Holidays valid 2006-2011 (obsolete) —
Dutch Holidays for 2006-2011: 

* Added Carnaval, Sint Maarten, Drie Koningen, Sinterklaas, Pakjesavond, Prinsjesdag, Dag van de Arbeid, Naturalisatiedag, Koninkrijksdag and Suikerfeest. 

* Deleted all X-MOZ info, Class etc to keep the file as clean as possible. 

* Altered Vaderdag and Moederdag. 

* Up till 2008 Koninkrijksdag and Naturalisatiedag were two different days, since 2008 they're on the same day (dec 15th). I decided not to work with exceptions on occurences to keep the ics as simple as possible for other programs to work with. 

* Added some info-links for ie Suikerfeest as this is not on the same day for all people. 

Pander, please look into this and let me know if you find any errors. Thanks Simon...
Bas, I have tested it.

When you have in Valentijnsdag, Sint Maarten, Driekoningen, then also Vaderdag and Moederdag should be in there. They have somewhat the same impact on the society and are important for most families, at least, when you don't forget it ;)

Secretaressedag crossed my mind but is one that should indeed not be in there because it discriminates other professions that don't get a special gift.

Is it possible to choose one of Naturalisatiedag and Koninkrijksdag?

Please remove the link on Suikerfeest, people know where to find info, also for other days like Sint Maarten, just go to Wikipedia. Or... provide links vor all, via dutch wikipedia. But perhaps too much. What do you think?

So far my results, it looks good.
TO keep it simple, also for other calendar tools, I would go for no attachments like the link on Suikerfeest. Keep is simple. Those were my 2 cents.
I don't know why vaderdag and moederdag were deleted, they're back. Kept both naturalisatiedag and koninkrijksdag. Removed all links to wikipedia etc.
Attachment #354786 - Attachment is obsolete: true
Bas, I have tested it again and it is perfect. Please have it published on the Mozilla holiday calendar page. Thanks you for your effort.
Updated file checked in. Thanks for your contribution, guys!
Status: ASSIGNED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Summary: Update Dutch Holidays calendar → Dutch Holidays 2006-2011
You need to log in before you can comment on or make changes to this bug.