Site overrides behavior of native keyboard shortcuts.

RESOLVED DUPLICATE of bug 380637

Status

()

RESOLVED DUPLICATE of bug 380637
10 years ago
6 years ago

People

(Reporter: david.zarlengo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

The site, http://bookoutlines.pbwiki.com, will steal the key that activates the Quick Find toolbar (default: '/'), and instead focus their own search box that has different semantics.

Reproducible: Always

Steps to Reproduce:
1. Navigate to http://bookoutlines.pbwiki.com
2. Press the Quick Find hotkey (default: '/')

Actual Results:  
The Quick Find toolbar did not appear as expected.  Instead, the site has switched focus to a search field that has different behavior than the Quick Find toolbar.

Expected Results:  
I *always* expect to be able to use the Quick Find toolbar on any site, and to be able to activate that feature by pressing the associated hotkey (again, '/').

This issue was tested on both Mac OSX and Windows XP.  I wasn't able to find a workaround.
(Reporter)

Comment 1

10 years ago
While, yes, I could use the Find toolbar to perform the search, doing so would remove the need to *ever* use the Quick Find feature.  If sites can intercept Quick Find hotkey, then there is no point for using it because each different site will tend to give it its own (and different) behavior.

Specifically, I don't want to be placed in a situation where I have to learn which sites intercept Quick Find and which do not.  Instead, I will tend to distrust and not use the Quick Find feature.

Also note that if I did change my behavior to use Find instead of Quick Find, PBwiki's search box would not be activated for a simple in-page search.  I think this gives more ammo to the argument that it's a bug that the Quick Find hotkey can be intercepted.
The site also overrides Ctrl-U. AFAICT it traps it in a keydown (or some such event) and then calls preventDefault().
Summary: Site overrides behavior of the Quick Find shortcut key '/'. → Site overrides behavior of native keyboard shortcuts.
Whiteboard: DUPEME

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 380637

Updated

6 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.