Some of the dom-level2-html tests trigger a 484 bytes leak, with Java SE 6 Update 1x NPAPI-based plugin

RESOLVED FIXED in mozilla1.9.2a1

Status

()

RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: sgautherie, Assigned: jaas)

Tracking

(Blocks: 1 bug, {memory-leak, regression})

Trunk
mozilla1.9.2a1
x86
Windows Server 2003
memory-leak, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.1 -
in-testsuite -

Firefox Tracking Flags

(status1.9.1 ?)

Details

(Whiteboard: [See comment 19])

(Reporter)

Description

10 years ago
I wanted to narrow down bug 471505 (on mozilla-1.9.1),
"instead" I found this one (on mozilla-central).

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20081230 SeaMonkey/2.0a3pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/6201c0669e15
 +http://hg.mozilla.org/comm-central/rev/2854a16a867f)

{
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 484 bytes during test execution (threshold set at 8 bytes)
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 1 instance of nsComponentManagerImpl with size 276 bytes
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 2 instances of nsLocalFile with size 88 bytes each (176 bytes total)
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 3 instances of nsStringBuffer with size 8 bytes each (32 bytes total)
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 2 instances of nsTArray_base with size 4 bytes each (8 bytes total)
}

In tests\dom\tests\mochitest\dom-level2-html,
any of test_HTMLBodyElement07.html to test_HTMLBodyElement12.html triggers this;
and some/all of test_HTMLDocument01.html to test_HTMLDocument27.html do too.
Flags: wanted1.9.2?

Comment 1

10 years ago
Does this leak also on ff or is this seamonkey only?
(Reporter)

Comment 2

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090101 Minefield/3.2a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/e807ec425ad7)

Same leak.

Why didn't the Firefox tinderboxes catch this ? :-/
Blocks: 408905
No longer blocks: 448125, 470184
Keywords: regression
Summary: [SeaMonkey, Windows] Some of the dom-level2-html tests trigger a 484 bytes leak → Some of the dom-level2-html tests trigger a 484 bytes leak
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> Why didn't the Firefox tinderboxes catch this ? :-/

Odd: "WINNT 5.2 mozilla-central unit test" (and Linux and MacOSX) reports "no leaks detected!" before/after/since bug 427878 checkin.

My build is on Windows 2000 and has --disable-vista-sdk-requirements...
Summary: Some of the dom-level2-html tests trigger a 484 bytes leak → Some of the dom-level2-html tests trigger a 484 bytes leak, on my Windows 2000
(Reporter)

Comment 4

10 years ago
Fwiw, I see this leak when running
|include ../../layout/base/crashtests/crashtests.list|
too.
(Reporter)

Comment 5

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b5pre) Gecko/20090424 SeaMonkey/2.0b1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/releases/mozilla-1.9.1/rev/d77750c8a7b8
 +http://hg.mozilla.org/comm-central/rev/b7fd81f51c6e)

I reproduce with 1.9.1 too.
(Reporter)

Comment 6

10 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1244579133.1244583196.14718.gz
WINNT 5.2 mozilla-1.9.1 unit test on 2009/06/09 13:25:33
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1244582652.1244588660.31973.gz
WINNT 5.2 mozilla-central unit test on 2009/06/09 14:24:12
crashtest + mochitest-plain

This started to happen on FF 3.5/3.6 box(es), with no checkins:
obviously related to the maintenance:
{
The following will be landed:
https://bugzilla.mozilla.org/show_bug.cgi?id=491298 and https://bugzilla.mozilla.org/show_bug.cgi?id=474572 - OPSI deployment on win32 slaves
https://bugzilla.mozilla.org/show_bug.cgi?id=495533 - Java update on win32 slaves
https://bugzilla.mozilla.org/show_bug.cgi?id=494971 - Add 10 new slaves to Talos Try
https://bugzilla.mozilla.org/show_bug.cgi?id=495610 - whitespace changes to some of our Buildbot code
}

Bug 495533 is the most probable candidate,
and I'm also using the new "Java(TM) Platform SE 6 U13" plugin atm!
Blocks: 495533
Flags: blocking1.9.2?
Flags: blocking1.9.1?
Keywords: regression
OS: Windows 2000 → Windows Server 2003
Summary: Some of the dom-level2-html tests trigger a 484 bytes leak, on my Windows 2000 → Some of the dom-level2-html tests trigger a 484 bytes leak, with Java SE 6 Update 1x NPAPI-based plugin
Whiteboard: [See comment 6]
Yeah, the Java update definitely tripped this. The leak appears to be in XPCOM - cc'ing :bs and :dougt since they're authorities in that component. If either of you has a few minutes, can you see if anything sticks out to you?

If we can't fix the leak we need to back out the java update, or set a threshold.

Comment 8

10 years ago
if you changed a npapi plugin, and we started leaking, i would start the blame in the new plugin.
Is there anyway we can confirm that? Would a backtrace help?
Doug made the excellent suggestion of removing the Java plugin and testing again. And indeed, without the java plugin we don't leak. I'm going to take the rest of this back to bug 495533, but it looks like we'll need a leak threshold to deal with the orange.

I'm working on a patch to do that so we can fix this perma-orange state.
Josh volunteered to track down this leak.
Assignee: nobody → joshmoz
Status: NEW → ASSIGNED
The Java upgrade on the Firefox builders is also hitting a 484 byte leak running crashtest. eg http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1244617102.1244625811.23152.gz - looks the same as comment #0.
(Reporter)

Comment 13

10 years ago
(In reply to comment #12)
> - looks the same as comment #0.

Reported in comment 4 and comment 6 indeed!
This only leaks when you instantiate the plugin, right? So when you actually run some DOM manipluation code that requires Java?

Don't think we'll block Firefox 3.5 on a 400 byte leak that only happens under those circumstances, please feel free to renominate if I'm misinterpreting.
Flags: wanted1.9.1.x?
Flags: blocking1.9.1?
Flags: blocking1.9.1-
(Reporter)

Comment 15

10 years ago
(In reply to comment #14)

(Fwiw, I think I have a real life JavaWebStart case (on a private "bank" site) where I see a continuous leak increase of SeaMonkey process "and" a shutdown hang of the external Java process (only).
But I haven't tried to confirm/pinpoint these yet.
Mentioning it here, just in case someone else would run into something like that.)

Updated

10 years ago
Blocks: 438871
Whiteboard: [See comment 6] → [See comment 6] [orange]
(Reporter)

Comment 16

10 years ago
Jesse, why abuse bug 438871? This is not intermittent.

Comment 17

10 years ago
Sorry, I saw orange attributed to an old bug and assumed it was intermittent.  I guess it's actually tied to the version of Java on each machine?
(In reply to comment #17)
> Sorry, I saw orange attributed to an old bug and assumed it was intermittent. 
> I guess it's actually tied to the version of Java on each machine?

For the record, all of the slaves running m-c, 1.9.1, and tracemonkey builds have Java 6 on them. Only the try slaves haven't been updated yet.
(Reporter)

Updated

10 years ago
No longer blocks: 438871
Whiteboard: [See comment 6] [orange] → [See comment 6]
(Reporter)

Updated

10 years ago
Blocks: 460548
(Reporter)

Comment 19

9 years ago
1.9.2 trunk:


http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1246020805.1246027759.11985.gz&fulltext=1
WINNT 5.2 mozilla-central unit test on 2009/06/26 05:53:25

Still leaks.


http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1246028465.1246036567.16139.gz&fulltext=1
WINNT 5.2 mozilla-central unit test on 2009/06/26 08:01:05

Doesn't leak anymore.

Fix timeframe:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2009-06-26+05%3A50%3A24&enddate=2009-06-26+07%3A58%3A06
A few changesets, related to (Java) Plugin!


[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090711 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/47bfcd275ede
 +http://hg.mozilla.org/comm-central/rev/291cbe3374b9)

No more leak either.


*****

1.9.1 branch:


http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1247342838.1247348243.6059.gz&fulltext=1
WINNT 5.2 mozilla-1.9.1 unit test on 2009/07/11 13:07:18

Still leaks.


http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1247314133.1247321343.27351.gz&fulltext=1
WINNT 5.2 comm-1.9.1 unit test on 2009/07/11 05:08:53

Does not leak.
KaiRo, which Java plugin do the Windows SeaMonkey boxes use? (Were they upgraded to v6r14?)
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: wanted1.9.2?
Flags: in-testsuite-
Flags: blocking1.9.2?
Resolution: --- → FIXED
Whiteboard: [See comment 6] → [See comment 19]
Target Milestone: --- → mozilla1.9.2a1

Comment 20

9 years ago
no upgrade to v6r14 was done, we still have build 1.5.0_10-b03 right now.
(Reporter)

Comment 21

9 years ago
(In reply to comment #20)
> no upgrade to v6r14 was done

Now done in bug 503507 and leaking (on m-1.9.1).
Blocks: 503807
status1.9.1: --- → ?
Flags: wanted1.9.1.x?
You need to log in before you can comment on or make changes to this bug.