Closed Bug 471671 Opened 13 years ago Closed 13 years ago

Multiple authentications when opening multiple tabs on start-up

Categories

(Firefox :: Tabbed Browser, defect)

x86
macOS
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 348997

People

(Reporter: d_j_p_3, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

After starting Firefox for the first time I have not authenticated to the password vault.

I then go to the bookmark bar and choose to "Open all in tabs"

This causes multiple tabs to be opened and loaded.  In my case, many of the tabs try and preload usernames and passwords (this is good).  Unfortunately, because I haven't authenticated yet the password manager bombards me with requests to enter my password.

This results in two bad behaviors:
  1) If I wait till everything is done loading I have to enter my password vault password multiple times.
  2) If I don't wait till everything is done loading I start to type my password and then the focus is stolen halfway through for the next tab to get access to the password vault.

Reproducible: Always

Steps to Reproduce:
1.Set up a bookmark folder with multiple webpages that Firefox wants to prefill wth form data.
2. Shut down Firefox to clear the password vault password.
3. Start up Firefox.
4. Open all webpages as tabs from that bookmark folder using "Open All in Tabs"
Actual Results:  
The user has to authenticate many (many) times to password manager.

Expected Results:  
After requesting authentication once, all other authentication requests should be blocked until the first one is completed.

There are obvious work arounds...
Thanks!  I love firefox which I why I bother to file a bug.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 348997
This may not be a direct dupe, but the patch there will fix this as well, and the underlying problem is pretty much the same.
You need to log in before you can comment on or make changes to this bug.