'FILE_ILLEGAL_CHARACTERS' : macro redefinition

VERIFIED DUPLICATE of bug 467015

Status

MailNews Core
Backend
VERIFIED DUPLICATE of bug 467015
9 years ago
9 years ago

People

(Reporter: timeless, Assigned: prasad)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
dbg-thunderbird-i686-pc-mingw32\mozilla\dist\include\xpcom\nsCRT.h(295) : warning C4005: 'FILE_ILLEGAL_CHARACTERS' : macro redefinition
dbg-thunderbird-i686-pc-mingw32\mozilla\dist\include\msgbase\msgCore.h(216) : see previous definition of 'FILE_ILLEGAL_CHARACTERS'
This is a side effect of being part way through the migration to frozen linkage. We can possibly ifndef it for MOZILLA_INTERNAL_API, we definitely don't want to remove the duplicate definition.
(Reporter)

Updated

9 years ago
Assignee: nobody → prasad
Depends on: 407295
I do believe serge found it first.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 467015
V.Duplicate
Status: RESOLVED → VERIFIED
Version: unspecified → Trunk
No longer depends on: 407295
You need to log in before you can comment on or make changes to this bug.