Last Comment Bug 471776 - Textboxes with emptytext shouldn't enable undo for display and deletion of empty text
: Textboxes with emptytext shouldn't enable undo for display and deletion of em...
Status: VERIFIED FIXED
: verified1.9.1
Product: Toolkit
Classification: Components
Component: XUL Widgets (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla1.9.2a1
Assigned To: Graeme McCutcheon [:graememcc]
:
Mentors:
: 476269 (view as bug list)
Depends on:
Blocks: 471319
  Show dependency treegraph
 
Reported: 2009-01-01 08:23 PST by Graeme McCutcheon [:graememcc]
Modified: 2009-04-04 11:07 PDT (History)
8 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (5.33 KB, patch)
2009-01-01 09:25 PST, Graeme McCutcheon [:graememcc]
enndeakin: review+
Details | Diff | Review
hg export for checkin [Checkin: Comment 6] (5.63 KB, patch)
2009-02-10 14:25 PST, Graeme McCutcheon [:graememcc]
mbeltzner: approval1.9.1+
Details | Diff | Review

Description Graeme McCutcheon [:graememcc] 2009-01-01 08:23:07 PST
Spinning this off from bug 471319...

That bug found a problem in the editor code with undo/redo. However, part of the problem is that undo shouldn't be enabled in the first place when there hasn't been a user edit.
Comment 1 Graeme McCutcheon [:graememcc] 2009-01-01 09:25:11 PST
Created attachment 355036 [details] [diff] [review]
Patch

When clearing empty text, try and clean up after ourselves.
Comment 2 Graeme McCutcheon [:graememcc] 2009-01-31 12:07:44 PST
*** Bug 476269 has been marked as a duplicate of this bug. ***
Comment 3 Henrik Skupin (:whimboo) 2009-01-31 12:49:01 PST
Gavin, do you have time to review this patch?
Comment 4 Graeme McCutcheon [:graememcc] 2009-02-09 12:22:53 PST
Comment on attachment 355036 [details] [diff] [review]
Patch

Neil, are you able to review this change at all?
Comment 5 Graeme McCutcheon [:graememcc] 2009-02-10 14:25:57 PST
Created attachment 361632 [details] [diff] [review]
hg export for checkin
[Checkin: Comment 6]
Comment 6 Serge Gautherie (:sgautherie) 2009-02-15 08:48:18 PST
Comment on attachment 361632 [details] [diff] [review]
hg export for checkin
[Checkin: Comment 6]


http://hg.mozilla.org/mozilla-central/rev/787fde278f78
Comment 7 Henrik Skupin (:whimboo) 2009-02-16 18:18:45 PST
Verified fixed with builds on OS X and Windows:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090216 Minefield/3.2a1pre ID:20090216020430
Comment 8 Mike Beltzner [:beltzner, not reading bugmail] 2009-03-27 10:47:02 PDT
Comment on attachment 361632 [details] [diff] [review]
hg export for checkin
[Checkin: Comment 6]

a191=beltzner
Comment 10 Henrik Skupin (:whimboo) 2009-04-04 11:07:38 PDT
Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090404 Shiretoko/3.5b4pre ID:20090404035045 and on Windows.

What about the location bar? It looks somewhat inconsistent in its behavior. Opening a new tab, clicking away, and opening its context menu still shows the undo entry enabled. I can go back several steps and at some point urls are shown which were entered in other tabs. Do we share the undo stack between tabs? I think that's a bug. I wanted to ask before I file a new bug on that issue.

Note You need to log in before you can comment on or make changes to this bug.