pref urlbar.autocomplete.enabled is no longer implemented

RESOLVED FIXED in mozilla1.9.2a1

Status

()

Toolkit
Places
P1
critical
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: dietrich, Assigned: Mardak)

Tracking

({fixed1.9.1, regression})

Trunk
mozilla1.9.2a1
fixed1.9.1, regression
Points:
---
Bug Flags:
blocking1.9.1 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
it's set during IE migration:

http://mxr.mozilla.org/mozilla-central/search?string=urlbar.autocomplete.enabled

and defined, but not used in Places:

http://mxr.mozilla.org/mozilla-central/ident?i=PREF_AUTOCOMPLETE_ENABLED


if it's a valid IE setting for toggling autocomplete and is turned off, we should set browser.urlbar.search.sources = 0.
(Assignee)

Comment 1

9 years ago
Seems to be used in suite.... ? somehow?

http://mxr.mozilla.org/comm-central/search?string=autocomplete.enabled&find=suite%2F
(Assignee)

Comment 2

9 years ago
Seamonkey is expecting autocomplete.enabled, and search.sources should probably go away per bug 472943.

We can fix both by changing search.sources=0 into autocomplete.enabled and then fix firefox ui to use default.behavior instead of search.sources for the dropdown.

I'll whip something up for trunk and probably request blocking 191 or something.
Blocks: 472943
Keywords: regression
Summary: pref urlbar.autocomplete.enabled is unused → pref urlbar.autocomplete.enabled is no longer implemented
Target Milestone: --- → mozilla1.9.2a1
(Assignee)

Comment 3

9 years ago
Created attachment 357376 [details] [diff] [review]
v1

Hook up the dropdown to two prefs and always update .enabled. Remove search.sources and switch turning off ability to check .enabled.
Assignee: nobody → edilee
Status: NEW → ASSIGNED
Attachment #357376 - Flags: review?(dietrich)
(Reporter)

Comment 4

9 years ago
setting p1, as mardak says it breaks AC for seamonkey
Severity: normal → critical
Priority: -- → P1
(Reporter)

Updated

9 years ago
Attachment #357376 - Flags: review?(dietrich) → review+
(Reporter)

Comment 5

9 years ago
Comment on attachment 357376 [details] [diff] [review]
v1

r=me. the pref is less easy to understand, but since we have UI for the common cases, i'm not so worried about it. the lack of confusion over two prefs is definite win.
(Assignee)

Comment 6

9 years ago
Moved pref to "toolkit.js" (all.js) from firefox.js.

http://hg.mozilla.org/mozilla-central/rev/68391d886801
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
(Assignee)

Comment 7

9 years ago
b191? as seamonkey has broken functionality with this regression.
Flags: blocking1.9.1?
(Assignee)

Updated

9 years ago
Attachment #357376 - Flags: approval1.9.1?
(Assignee)

Comment 8

9 years ago
Comment on attachment 357376 [details] [diff] [review]
v1

a191? to fix seamonkey. Has tests and cleans up prefs.
Flags: blocking1.9.1? → blocking1.9.1+
(Assignee)

Updated

9 years ago
Attachment #357376 - Flags: approval1.9.1?
(Assignee)

Comment 10

9 years ago
dev-doc-needed: Just incase the pref was lost in the docs somewhere along the way because it wasn't implemented earlier.
Keywords: dev-doc-needed
We don't really have documentation for these sorts of preferences at all right now.  There's a separate bug already for adding documentation to cover prefs, so I'm removing teh doc needed tag here.
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.