Camino doesn't yet display ICC version 4 colors

VERIFIED DUPLICATE of bug 418538

Status

Camino Graveyard
General
--
enhancement
VERIFIED DUPLICATE of bug 418538
10 years ago
10 years ago

People

(Reporter: Albo P. Fossa, Unassigned)

Tracking

Trunk
x86
Mac OS X

Details

(Whiteboard: DUPME, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9.0.6pre) Gecko/2008121820 Camino/2.0b1 (like Firefox/3.0.6pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9.0.6pre) Gecko/2008121820 Camino/2.0b1 (like Firefox/3.0.6pre)

The listed URL is a test website containing a test image with ICC color profiles. The image displays properly in Safari, Firefox 3.1b2, and Shiira. Opera and Camino 2.0b1 do not yet have this ability. (Specific System is MacOSX 10.5.6)

Reproducible: Always

Steps to Reproduce:
1. Visit the specified URL
2. Compare the image at top of page to the descriptions further down the page.

Actual Results:  
The image as displayed matches the test results described as "The system does not support these ICC profiles"

Expected Results:  
The image as displayed should match the test results described as "The system supports these ICC version 4 and version 2 profiles"

Please visit the specified website.

Comment 1

10 years ago
As the user agent says, Camino 2.0 is like Firefox 3.0 (based on Gecko 1.9.0), and Gecko 1.9.0 doesn't support them. This is a dup of whatever the core bug is.
Whiteboard: DUPME
Version: unspecified → Trunk

Comment 2

10 years ago
According to bholley, Gecko 1.9.0 *should* support ICC4 profiles, so I'm ccing him for further help here.
So my impression from the report is that _no_ color management is happening, not just no ICC4. I would find it very strange if we had icc2 but not icc4 support anywhere in mozilla, since they're both done with lcms, which was added as a blob.

Up until last september, color management was disabled by default in the mozilla platform. We eventually flipped it on by changing gfx.color_management.mode from 0 to 2 in libpref/src/init/all.js. I don't know much about camino, but I'm guessing it uses the same prefs. If this is the case, any camino based on 1.9.0 should not have color management enabled by default, whereas any camino based on 1.9.1+ should have it enabled by default.

Comment 4

10 years ago
Bobby pointed out that the bug as filed sounds like *no* colour management is happening at all, and I see the "right" image (basically a match to the first screenshot) on both an Intel iMac and on my PowerBook G4.

Make sure gfx.color_management.enabled is set to true in about:config; if it's not, that would certainly explain the behaviour.
Right, this is a dupe of bug 418538; with CMS off, you see the third image [no color mgmt]; with CMS on (setting the hidden pref to true), you see the first image [v2 and v4 profiles].

You can enable the slow/buggy Gecko 1.9.0 color management support by setting the hidden pref gfx.color_management.enabled to true.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 418538

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.