If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Session Restore is not restoring anything when Firefox is quit nicely.

RESOLVED DUPLICATE of bug 398817

Status

()

Firefox
Session Restore
--
major
RESOLVED DUPLICATE of bug 398817
9 years ago
9 years ago

People

(Reporter: David Caldwell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090102 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090102 Shiretoko/3.1b3pre

I have the "Show my windows and tabs from last time" option selected in the preferences, but when I close FireFox (Shiretoko) the sessionstore.js file gets deleted from my profile. So when I start FireFox up I get just a blank window and not my last set of tabs.

Reproducible: Always

Steps to Reproduce:
1. Open a window
2. Quit Firefox
3. Launch Firefox
Actual Results:  
I get a blank window.

Expected Results:  
I want my last set of windows and tabs.

I've been working around this my manually copying the sessionstore.js file somewhere before I quit Firefox. It appears to be updated correctly (all my newest tabs and windows are in there). But when I select "quit" or let Firefox restart to update itself or some plugins the file gets deleted.

Interestingly, when I copy the sessionstore.js back after Firefox has quit and relaunched, it tells me that my browser was shutdown unexpectedly.

If I force quit Firefox then it (perhaps obviously) doesn't delete the file and so I get my windows back the next time it launches.

Comment 1

9 years ago
Please reopen this bug if you're not having Shiretoko clear your private data at shutdown (of which sessionstore.js is part).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 398817
You need to log in before you can comment on or make changes to this bug.