If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Spyware Doctor: Bookmark url location disappears periodically

VERIFIED INVALID

Status

()

Firefox
Bookmarks & History
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: hthehut, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Two of my bookmarks have their url locations disappear periodically on two different computers.  They are http://www.ebates.com/ and http://www.pricegrabber.com/.  [Note: This bug report is for informational purposes so hopefully an article will be created.  I have determined the cause and the "solution".  This similar disappearing location problem is reported by many people and has responded with the probably cause and solution for all of these people.]  I am not sure if the FireFox developers can resolve this.

Reproducible: Sometimes

Steps to Reproduce:
1. After turning on my computers in the morning and sometimes periodically throughout the day the two bookmark url locations listed disappear.
2. Restore all bookmarks from a backup file, (everything is there).
3. Later in the day they may disappear, (sometimes they don't).
Actual Results:  
The two bookmark url locations disappear, (and then the names can't be deleted).

Expected Results:  
The two bookmark url locations should stay.

I am running Windows XP Pro with all of the latest updates, McAfee Internet Security with all of the latest updates and PC Tools Spyware Doctor with all of the latest updates.  PC Tools Spyware Doctor is the cause of the disappearance and can be used to "resolve" the disappearing problem as well.  Every morning at 9AM I have PC Tools Spyware Doctor set to run an Intelli-scan and I also have it set to run a Full scan on a weekly basis.  After an update it also runs a quick scan, which is the reason for the "sometimes periodically throughout the day" appearance of the problem.  If I restore the bookmarks, (and all is fine), then run the Intelli-scan, the locations for these two bookmarks disappear every time.  The "fix" is to add them as exclusions in the Cookie Guard under the IntelliGuard Protection of PC Tools Spyware Doctor.  I am not sure if FireFox can fix the problem permanently, but by having it added to the knowledge base would solve the frustration of a lot of FireFox users.
Version: unspecified → 3.0 Branch
(Reporter)

Comment 1

9 years ago
Created attachment 355233 [details]
ebates.com bookmark with missing location
(Reporter)

Comment 2

9 years ago
Created attachment 355234 [details]
pricegrabber.com bookmark with missing location
(Reporter)

Comment 3

9 years ago
Created attachment 355235 [details]
PC Tools Spyware Doctor - FireFox bookmark url location disappearance "fix"
Bugzilla is not the right place for that as this can't be fixed by us because it's an external application that modifies the bookmark file.

Please send a note to the spyware Doctor developers that they should fix their product because only they can fix it.
That you have to add it under the cookie list shows that there is a bug in their product. The bookmarks and the cookies are stored in one single file with FF3 and it seems that they think that the bookmark entry looks like a cookie.
You should can add a Forum post at http://support.mozilla.com because the knowledge base is part of the support while bugzilla is a place for the developers.

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Summary: Bookmark url location disappears periodically → Spyware Doctor: Bookmark url location disappears periodically
v.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

9 years ago
I added a Forum post, thank-you.  I also sent PC Tools / Spyware Doctor an email.  Perhaps a "FireFox" fix could be in separating the bookmarks from the cookies and not storing them in one single file?
(In reply to comment #6)
> I added a Forum post, thank-you.  I also sent PC Tools / Spyware Doctor an
> email.  Perhaps a "FireFox" fix could be in separating the bookmarks from the
> cookies and not storing them in one single file?
We don't store them in the same file
My mistake, cookes are stored in a different file, only bookmarks and history share the same file. It makes even less sense that they are modifying places.sqlite, they should not touch it. if more and more tools are writing into places.sqlite it would explain that many users got corrupted bookmarks.
(Reporter)

Comment 9

9 years ago
I have modified my Forum post, thank-you.  Again, perhaps a "FireFox" fix could be by blocking the modification of places.sqlite by software that is not FireFox 3, maybe by encrypting it with something associated with the profile)?
encrypting the bookmarks&history would hurt the performance very badly and it would not stop other software from modifying it because they still can decrypt the files.
(Reporter)

Comment 11

9 years ago
I have contacted PC Tools and the following denial is their response:

"Thank you for contacting PC Tools. 

Looking at the History log, Spyware Doctor did not remove anything related to bookmarks or any other files besides cookies. 

If you require further assistance on this specific request, please reply to this email."

I replied and copied the above conversation that occurred here on Bugzilla along with the pictures.  Hopefully they will own up to it and fix it.
You need to log in before you can comment on or make changes to this bug.