is3 anti-spyware STOPzilla crashes [@ SGPrxy.dll@0x25de] (LSP) [@ SGPrxy.dll@0x259e ]

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
--
critical
RESOLVED WORKSFORME
9 years ago
3 years ago

People

(Reporter: timeless, Assigned: JimD)

Tracking

(Blocks: 1 bug, {crash, topcrash})

Details

(Whiteboard: [crashkill][crashkill-outreach], crash signature)

(Reporter)

Description

9 years ago
someone needs to contact is3.com (they have a livechat, but it doesn't seem to be open 24x7).

to anyone else reading this bug, it's not our fault. is3 has installed a Layered Service Provider (LSP) <http://en.wikipedia.org/wiki/Layered_Service_Provider> and it's buggy :).

Signature	@0x0
UUID	ef4f3142-d2ee-4199-af45-0a7182081220
Time	2008-12-20 17:25:19-08
Uptime	76
Last Crash	115178 seconds before submission
Product	Firefox
Version	3.2a1pre
Build ID	20081219034805
Branch	1.9.2
OS	Windows NT
OS Version	6.0.6001 Service Pack 1
CPU	x86
CPU Info	GenuineIntel family 15 model 6 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x0
0		@0x0	
1	SGPrxy.dll	SGPrxy.dll@0x25de	
2	iS3lsp.dll	iS3lsp.dll@0x4a16	
3	ws2_32.dll	ws2_32.dll@0x3355	
4	ws2_32.dll	ws2_32.dll@0x4a70	
5	ws2_32.dll	ws2_32.dll@0x4a07	
6	ws2_32.dll	ws2_32.dll@0x4810	
7	ws2_32.dll	ws2_32.dll@0x37b8	
8	ws2_32.dll	ws2_32.dll@0x41e7	
9	SGPrxy.dll	SGPrxy.dll@0x55de	
10	nspr4.dll	_PR_NativeRunThread	nsprpub/pr/src/threads/combined/pruthr.c:436
11	nspr4.dll	pr_root	nsprpub/pr/src/md/windows/w95thred.c:122
12	mozcrt19.dll	_callthreadstartex	obj-firefox/memory/jemalloc/src/threadex.c:348
13	mozcrt19.dll	_threadstartex	obj-firefox/memory/jemalloc/src/threadex.c:326
14	kernel32.dll	kernel32.dll@0x44910	
15	ntdll.dll	ntdll.dll@0x3e4b5	
16	ntdll.dll	ntdll.dll@0x3e488	

iS3lsp.dll	2.7.2.116	99F38803F0E24569A0C279C323312B8F1	iS3lsp.pdb
SGPrxy.dll	5.0.20.72	FC6F5E74161C433EB843583DECF4326F1	SGPrxy.pdb
iS3SploitChecker.dll	2.7.2.117	1290324675E449969278F0A50AA98B6F1	iS3SploitChecker.pdb
iS3SiteBlocker.dll	2.7.2.117	447AD343F684449DA95570D1A2C00C1F1	iS3SiteBlocker.pdb
A user on sumo with this crash (bp-7421a8b5-8302-4bdb-ad9e-c37602090422) fixed it by removing this LSP

Confirming and moving to tech evangelism
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: Shell Integration → English US
Ever confirmed: true
Product: Firefox → Tech Evangelism
QA Contact: shell.integration → english-us
Version: Trunk → unspecified

Comment 2

9 years ago
I am getting these same Firefox crashes multiple times a day:

Firefox 3.5 Crash Report [@ SGPrxy.dll@0x258e ]
Get Help
ID: f63c4543-5547-4c2a-b522-f014f2090710
Signature: SGPrxy.dll@0x258e

    * Details
    * Modules
    * Raw Dump

Signature	SGPrxy.dll@0x258e
UUID	f63c4543-5547-4c2a-b522-f014f2090710
Time 	2009-07-10 17:49:09.280350
Uptime	1843
Last Crash	15808 seconds before submission
Product	Firefox
Version	3.5
Build ID	20090624025744
Branch	1.9.1
OS	Windows NT
OS Version	6.0.6001 Service Pack 1
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 13
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0xffffffffffc00257
User Comments	Still another Firefox crash--not much of a surprise.
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 		@0xffc00257 	
1 	SGPrxy.dll 	SGPrxy.dll@0x258e 	
2 	iS3lsp.dll 	iS3lsp.dll@0x4a66 	
3 	ws2_32.dll 	ws2_32.dll@0x3355 	
4 	ws2_32.dll 	ws2_32.dll@0x59d6 	
5 	ws2_32.dll 	ws2_32.dll@0x48c7 	
6 	ws2_32.dll 	ws2_32.dll@0x37b8 	
7 	ws2_32.dll 	ws2_32.dll@0x41e7 	
8 	SGPrxy.dll 	SGPrxy.dll@0x55ae 	
9 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
10 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
11 	mozcrt19.dll 	_callthreadstartex 	obj-firefox/memory/jemalloc/src/threadex.c:348
12 	mozcrt19.dll 	_threadstartex 	obj-firefox/memory/jemalloc/src/threadex.c:326
13 	kernel32.dll 	kernel32.dll@0x44910 	
14 	ntdll.dll 	ntdll.dll@0x3e4b5 	
15 	ntdll.dll 	ntdll.dll@0x3e488

Comment 3

9 years ago
Please report this to is3.com

Comment 4

9 years ago
This is the #38 topcrash for Firefox 3.5.2.
Keywords: topcrash
Summary: is3 antispyware crashes [@ 0x0 - SGPrxy.dll@0x25de] (lsp) → is3 anti-spyware STOPzilla crashes [@ SGPrxy.dll] (LSP)

Updated

8 years ago
Whiteboard: [crashkill][crashkill-outreach]

Updated

8 years ago
Summary: is3 anti-spyware STOPzilla crashes [@ SGPrxy.dll] (LSP) → is3 anti-spyware STOPzilla crashes [@ SGPrxy.dll@0x25de] (LSP)

Updated

8 years ago
Assignee: english-us → dsicore
On the phone with them now.
(Assignee)

Comment 6

8 years ago
An is3 employee is now CC'ed on this bug.
JimD.
(Reporter)

Comment 7

8 years ago
thanks damon. jimd: i'm assigning the bug to you, this is merely a form of book keeping. when you guys have resolved it, you can merely provide some comment indicating a fixed version and we'll resolve this bug or something.

thanks in advance for working with us. if you have any questions, just ask here, most likely zzxc will help you out.
Assignee: dsicore → mozilla
FYI, [@SGPrxy.dll@0x259e ] is now #80 on the top crash list for Firefox 3.6b4:
http://crash-stats.mozilla.com/query/query?product=Firefox&version=Firefox%3A3.6b4&date=&range_value=1&range_unit=weeks&query_search=signature&query_type=exact&query=&do_query=1
Summary: is3 anti-spyware STOPzilla crashes [@ SGPrxy.dll@0x25de] (LSP) → is3 anti-spyware STOPzilla crashes [@ SGPrxy.dll@0x25de] (LSP) [@SGPrxy.dll@0x259e ]
(Assignee)

Comment 9

8 years ago
We are in the process of finalizing a release that will eliminate the LSP (a third party product), however it takes time to get everyone to upgrade.
The release will ship in about 2 weeks.
(Assignee)

Updated

8 years ago
OS: Windows XP → Windows Vista
(Reporter)

Updated

8 years ago
Summary: is3 anti-spyware STOPzilla crashes [@ SGPrxy.dll@0x25de] (LSP) [@SGPrxy.dll@0x259e ] → is3 anti-spyware STOPzilla crashes [@ SGPrxy.dll@0x25de] (LSP) [@ SGPrxy.dll@0x259e ]
(Reporter)

Updated

8 years ago
Duplicate of this bug: 534457

Updated

8 years ago
Blocks: 534896
Crash Signature: [@ SGPrxy.dll@0x25de] [@ SGPrxy.dll@0x259e ]

Comment 11

6 years ago
There have been no crashes with their signature containing SGPrxy for the last four weeks.
I close it as WFM.
Status: NEW → RESOLVED
Crash Signature: [@ SGPrxy.dll@0x25de] [@ SGPrxy.dll@0x259e ] → [@ SGPrxy.dll@0x25de] [@ SGPrxy.dll@0x259e ]
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.