Closed Bug 472117 Opened 11 years ago Closed 11 years ago

links don't work; status area shows "c._oldDisplay is undefined" in hotmail/InboxLight

Categories

(SeaMonkey :: General, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 462428

People

(Reporter: lode_leroy, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090104 SeaMonkey/2.0a3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090104 SeaMonkey/2.0a3pre

hotmail does not work with seamonkey2

This is the relevant javascript statement that fails, compared to FF3

c._oldDisplay = window.CSSStyleDeclaration.prototype.__lookupSetter__("display");
c._oldDisplay.call(c,window)

(see "additional information" below)

Reproducible: Always

Steps to Reproduce:
1.log in to hotmail
2.look at the "inbox"
3.click on a message
Actual Results:  
status area shows "c._oldDisplay is undefined"

Expected Results:  
message content should be displayed

// code extract from http://gfx6.hotmail.com/mail/13.2.0260.1209/cmpt0.js

window.addEventListener("load",function(){
        var a = window;
        function b() {...};
        var c = a.CSSStyleDeclaration;
        c._oldDisplay=c.prototype.__lookupSetter__("display");
        alert("on_resize::load " + c._oldDisplay)
/*
   in Firefox/3.0.1
+--------------------------------------------------+
+  on_resize::load getter function display() {     +
+     [native code]                                +
+ }                                                +
+--------------------------------------------------+
   in SeaMonkey/2.0a3pre
+--------------------------------------------------+
+  on_resize::load undefined                       +
+--------------------------------------------------+
*/
        c.prototype.__defineSetter__(
           "display",
           function(a){c._oldDisplay.call(this,a);b();});}
           ,false);

/*
          throws exception in SeaMonkey/2.0a3pre
*/
       },false);
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 462428
You need to log in before you can comment on or make changes to this bug.