Last Comment Bug 472271 - Customized menu item shortcuts via Keyboard and Mouse system preference pane result in BALD-FACED LIES
: Customized menu item shortcuts via Keyboard and Mouse system preference pane ...
Status: VERIFIED DUPLICATE of bug 429824
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 3.0 Branch
: All Mac OS X
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 473596
  Show dependency treegraph
 
Reported: 2009-01-06 01:01 PST by Simone Manganelli
Modified: 2010-10-21 21:40 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Simone Manganelli 2009-01-06 01:01:52 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_6; it-it) AppleWebKit/528.8+ (KHTML, like Gecko) Version/4.0dp1 Safari/526.11.2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

When using Firefox, I expect it to respect system-wide settings.  System-wide settings make me happy, because that way I can get all my apps to perform the same way.  One category of such happy settings are the customized keyboard shortcuts from the Keyboard and Mouse system preference pane.

The Keyboard and Mouse system preference pane makes me happy.  It makes me happy because I can customize inane and ridiculous default shortcuts.  One such example would be the Downloads shortcut in Firefox.  The default shortcut for the Downloads window is Command-J.  "But wait!" you might cry out.  "The letter 'J' does not appear anywhere in the word 'Downloads'!"  You would be right.  And this makes me sad.

But I like happy things.  The Keyboard and Mouse system preference pane makes me happy!  I can change the shortcut for the Downloads window to something that makes me happy, too!  That way we can all be happy.  I like the keyboard shortcut Command-Option-L.  Command-D is already taken by the command "Bookmark This Page".  (If you noticed that the letter 'D' does not appear anywhere in the phrase "Bookmark This Page", you get a cookie!)  At least the letter 'L' appears in the word "Downloads".  Plus, it's Safari's shortcut for the Downloads window and everybody knows that Safari's shortcuts are awesome.

Firefox, however, does not like my happy new keyboard shortcut.  It eats it up.  IT EATSES IT UP LIKE GOLLUM EATSES FISHES.  TRICKSY FIREFOXSES!

What does Firefox do?  It flat-out bald-faced lies.  I open up the Tools menu (because, you know, the Downloads window is a *tool* and not a *window*, RIGHT?) and look at the keyboard shortcut, which now says Command-Option-L, as it should.  BUT IT'S A BIG, FAT, NASTY BALD-FACED LIE.

Because you know what happens when I press Command-Option-L?  Firefox flashes the Tools menu, BUT NOTHING HAPPENS.  That's right.  Firefox lied to you.  It told you it was going to go and get you flowers and chocolates and cook you a nice Italian dinner and then it was going to OPEN THE FRIGGIN' DOWNLOADS WINDOW.  But noooooo... Firefox runs off with your friggin' *ex* and leaves you there **** out of luck with NO FRIGGIN' DOWNLOADS WINDOW.

And to top it all off, Firefox taunts you.  It *actually flashes the Tools menu* to indicate that it received your command.  But then it's all, *NUH UH GIRLFRIEND* (cue air finger snaps) and doesn't do what you tell it to do.

No, Firefox wants you to use the *original* keyboard shortcut that YOU WERE FRIGGIN' TRYING TO CHANGE IN THE FIRST PLACE.  It's all, ohhh yeah, you can change the shortcut to the Downloads window nooooo problem but it still wants you to use that original keyboard shortcut.  It's like a bad car mechanic who friggin' fixes that annoying sound that's coming from your engine by putting friggin' ear plugs in your ears so you can't hear it anymore and you're looking at him all, "WTF, mate?!" and then your engine BURSTS INTO FRIGGIN' FLAMES and the mechanic's all, "What, I fixed it?  I FLASHED YOUR FRIGGIN' TOOLS MENU JUST LIKE YOU ASKED."

I swear.

How hard is it to respect the system-wide keyboard shortcut settings.  And, you know, if Firefox insists on not using the customized shortcuts, the very *least* it could do is not FRIGGIN' TELL YOU A BALD-FACED LIE TO YOUR FRIGGIN' FACE.

Reproducible: Always

Steps to Reproduce:
1. Open System Preferences.
2. Open the Keyboard and Mouse system preference pane.
3. Click the "Keyboard Shortcuts" tab.
4. Click the "+" button to add a new shortcut.
5. Select "Firefox" in the Applications pop-up menu, type "Downloads" in the Menu Title text field, and then click in the Keyboard Shortcut field and press Command-Option-L.
6. Click the "Add" button.
7. Quit System Preferences.

Here comes the friggin' bald-faced lie...

8. Launch Firefox.

Waaaait for it...

9. Click on the Tools menu to open it.

BOOOM!  BALD-FACED LIE!  (Note that the keyboard shortcut next to "Downloads" is Command-Option-L.)

10.  Close the Tools menu.

Waaaaait for it...

11.  Press Command-Option-L.

BOOOOOOOM!  BALD-FACED LIE!  (Note that the Tools menu flashes, but nothing happens.)

12.  Press Command-J.

Whaaaaat the ass?!  (Note that the Downloads window opened, using the *original* default keyboard shortcut.)
Actual Results:  
Firefox straight up bald-faced lies to your face.  It only performs the appropriate action when the original, default keyboard shortcut is pressed, even though the menu item says it responds to the keyboard shortcut from the Keyboard and Mouse system preference pane, and even though the friggin' menu flashes when you press the new keyboard shortcut.

Expected Results:  
Do I really have to outline what needs to be fixed?

...

Fine.  Fix Firefox so that menu items ACTUALLY RESPOND to keyboard shortcuts defined in the Keyboard and Mouse system preference pane.  Ugh.
Comment 1 Tyler Downer [:Tyler] 2009-01-06 07:52:08 PST
Try in Safe Mode. Also update to FF 3.0.5.
Comment 2 Simone Manganelli 2009-01-06 08:34:30 PST
Updated to Firefox 3.0.5, build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

Problem still exists; Firefox is still running off with my ex. :(
Comment 3 Neil Deakin 2009-01-06 08:39:39 PST

*** This bug has been marked as a duplicate of bug 429824 ***
Comment 4 pendolino 2009-02-26 17:50:10 PST
this is a pain in the A@#! when are you going to fix it FF team?
Comment 5 Tyler Downer [:Tyler] 2009-02-27 09:54:14 PST
bug 429824 is where this is being worked on.

Note You need to log in before you can comment on or make changes to this bug.