headless and unattended update

RESOLVED DUPLICATE of bug 231062

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 231062
10 years ago
8 years ago

People

(Reporter: stlman, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-05-28])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9) Gecko/2008052906 Firefox/3.0

Firefox and Thunderbird require user interaction when doing update. This makes site with more than few computers and users without elevated permissions hard to keep up to date.

Reproducible: Always

Steps to Reproduce:
1. Check for an update.

Actual Results:  
If you work as a restricted user you can't overwrite firefox files in Program Files (that's good of course). On the other hand, you must log in to every single machine with at least rdesktop/mstsc and manually run firefox.

Expected Results:  
Updates should be automatable with either task scheduler or remote execution tools like psexec or winexe. In both cases non-interactive path is required and in case of remote exec tools FF (and TB) must not use display.
Component: General → Application Update
Product: Firefox → Toolkit
QA Contact: general → application.update
Version: unspecified → Trunk

Comment 2

9 years ago
Please update if you are able to still reproduce and also update did the link mentioned in  Comment 1 helped you?
Whiteboard: [closeme 2010-05-28]
(Reporter)

Comment 3

9 years ago
This is only half the solution. What I would like to see is an "/update" switch which would:

1. check for available updates
2. download and
3. apply them.

The proposed solution does only the third step. What I hate about the first step is quite complicated scheme for paths where updates are available. Maybe if the linked article contained detailed description of how to check for an update and download it would be enough to develop proper scripts.
The functionality (and more) that you are looking for will be added in bug 231062, so marking as a dupe of that.

In the meantime, have you tried the MSI builds here?
http://www.frontmotion.com/Firefox/
(Unofficially built, but many companies use them with no problem)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Version: Trunk → 1.9.0 Branch
Duplicate of bug: 231062
You need to log in before you can comment on or make changes to this bug.