No small icons in edit event/task dialog available

RESOLVED FIXED in 1.0b2

Status

Calendar
Dialogs
--
minor
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Andreas Treumann, Assigned: Taraman)

Tracking

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

10 years ago
STEPS TO REPRODUCE:
===================

- open the edit event/task dialog
- open the customize toolbar dialog
- check the 'Use Small Icons' control

RESULT:
=======

- the icon size isn't changed

EXPECTED RESULT:
================

- a toolbar with small icons

REPRODUCIBLE:
=============

- always

Comment 1

10 years ago
For the toolbar icons in the dialog no small version is available (see calendar/base/themes/[w|p]instripe/dialogs/calendar-event-dialog-toolbar.png)
Component: General → Dialogs
QA Contact: general → dialogs
Duplicate of this bug: 526894
(Assignee)

Comment 3

9 years ago
Can we disable the option in the customize dialog?
(Assignee)

Comment 5

9 years ago
If the Small Icons are at hand, that is the better solution.

Taking over then.
Assignee: nobody → Mozilla
Status: NEW → ASSIGNED
(Assignee)

Comment 6

9 years ago
Created attachment 423867 [details] [diff] [review]
Patch V1

Built and tested ok on Windows with winstripe theme.

Pinstripe unchecked.
Attachment #423867 - Flags: ui-review?(clarkbw)
Attachment #423867 - Flags: review?(ssitter)
(Assignee)

Comment 7

9 years ago
Created attachment 423869 [details] [diff] [review]
Patch V1.1 - include .png files

forgot to include the images... ;-(
Attachment #423867 - Attachment is obsolete: true
Attachment #423869 - Flags: ui-review?(clarkbw)
Attachment #423869 - Flags: review?(ssitter)
Attachment #423867 - Flags: ui-review?(clarkbw)
Attachment #423867 - Flags: review?(ssitter)
Attachment #423869 - Flags: ui-review?(clarkbw)
Attachment #423869 - Flags: review?(ssitter)
Attachment #423869 - Flags: review+
Comment on attachment 423869 [details] [diff] [review]
Patch V1.1 - include .png files


>--- a/calendar/base/themes/pinstripe/dialogs/calendar-event-dialog.css
>+++ b/calendar/base/themes/pinstripe/dialogs/calendar-event-dialog.css
> 
>+toolbar[iconsize="small"] #button-save {
>+  -moz-image-region: rect(0px 144px 24px 1620px);
>+}
>+toolbar[iconsize="small"] #button-save[disabled="true"],
>+toolbar[iconsize="small"] #button-save[disabled="true"]:hover,
>+toolbar[iconsize="small"] #button-save[disabled="true"]:hover:active {
>+  -moz-image-region: rect(48px 144px 72px 120px);
>+}

I think 1620px should be 120px, otherwise the patch looks fine to me.

r=ssitter. I don't think we need ui-review because we just add the small version of the existing icons.
(Assignee)

Comment 9

9 years ago
Created attachment 424963 [details] [diff] [review]
Patch V1.2

>+  -moz-image-region: rect(0px 144px 24px 1620px);
>I think 1620px should be 120px, otherwise the patch looks fine to me.

Damn, I knew I would miss a typo in this. ;-)

And I found one more:
+toolbar[iconsize="small"] #button-spellcheck {
+    -moz-image-region: rect(0px 48px 216px 32px);
which should read 16 iso 216

Patch updated
Attachment #423869 - Attachment is obsolete: true
Attachment #424963 - Flags: review+
(Assignee)

Comment 10

9 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/0a8ce305dbdc>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Target Milestone: 1.0 → 1.0b2

Comment 11

9 years ago
verified with

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9pre) Gecko/20100204 Calendar/1.0b2pre
Status: RESOLVED → VERIFIED
(In reply to comment #11)

How? This fix is not available in comm-1.9.1 based builds like Sunbird 1.0b2pre.
Status: VERIFIED → RESOLVED
Last Resolved: 9 years ago9 years ago
You need to log in before you can comment on or make changes to this bug.