Closed Bug 472591 Opened 13 years ago Closed 8 years ago

abc.go.com - ABC full episode video player doesn't work on Linux

Categories

(Web Compatibility :: Desktop, defect)

x86
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: rhharper, Unassigned)

References

()

Details

(Keywords: top100, Whiteboard: [country-us] [notcontactready] [video])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20

The full episode player will not work under FF3.0.

Uninstall 3.0, installed 2.0.0.11 -- player works fine.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Works fine for me, tried it with this url http://fep.abc.go.com/fep/player?src=abccomjs&show=166626

Please see http://quality.mozilla.org/bug-writing-guidelines
Summary: Player → ABC player doesn't work in Firefox 3.0
While likely a UA sniffer issue, does not even try to play with trunk builds

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090107 Minefield/3.2a1pre Firefox/3.0.4 ID:20090107135852
Yeah the trunk problem is ua sniffing, setting general.useragent.override to Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 fixes it. This bug however was filed against 3.0 Branch.
Version: unspecified → 3.0 Branch
Went to test and it doesn't like Linux at all:

Oops
Our new video player is only available for:
Windows XP/Vista - Internet Explorer, Firefox
Mac - Firefox, Safari.
To watch, please download the appropriate browser.

I guess it's telling me to go download Windows XP or Mac OS X.  ;)

I gave it a test in a WinXP VM with both FF3 and FF2. Got the same result with both: asked for Flash and installed, asked for their own garbage "Move Movie Player" and installed, stall on play attempt. Also got error code "player_'Video';'2';'Unable to create adequate video renderer'" (without double quotes) on the first try, which makes me think it doesn't like my video drivers here, even though Flash video plays just fine normally. No help from me here other than to say that their player isn't quite perfect.

Please provide more info. What does it say/do when it doesn't work for you? Error? Stall?

In any case, over to TE.
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Summary: ABC player doesn't work in Firefox 3.0 → abc.go.com - ABC player doesn't work in Firefox 3.0
Version: 3.0 Branch → unspecified
Also see bug 379193.

There's also bug 433277 which this may be a duplicate of, depending on your symptoms.
I'm withdrawing my complaint.

After reading the feedback this "bug" received, I decided to try to duplicate the problem on a WinXP machine, and the worked okay.

I did, however, have to wrestle with my security settings (cookies, pop-up ads, etc.) before the player would play.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
In reference to bug 379193, my problem was the player window would just sit there with a circling comet cursor, endlessly circling. The video would never launch.

I thought I had disabled my security settings. I suppose, in my frustration, I might have neglected to do that.
(In reply to comment #7)
> In reference to bug 379193, my problem was the player window would just sit
> there with a circling comet cursor, endlessly circling. The video would never
> launch.

Yes, I got the endlessly circling cursor when it was stalling for me. It seems there are definitely a few things that can tick this player off enough to not work, though it apparently can be configured to work one way or another.
The video plays just fine once you get it to load, but there's definitely broken sniffing going on here. It works fine with the default Camino user-agent string, but if I remove the "like Firefox" portion, it fails. That sounds like a dupe of bug 379193 to me.

Do we have any contacts at ABC?
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 379193
I now have FF 2.0.0.20 and FF 3.0.5 running side-by-side.

Player works in 2 -- NG in 3. Same security settings. One launched within seconds of the other. Go figure.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Does anyone still see problems with this?
The ABC full episode player works for me with Firefox 3.6 on Windows, but doesn't seem to work on Linux as someone else has commented. OS -> Linux
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: top100
OS: Windows 2000 → Linux
Summary: abc.go.com - ABC player doesn't work in Firefox 3.0 → abc.go.com - ABC full episode video player doesn't work on Linux
this needs to be tested on Linux.
Assignee: english-us → nobody
Component: English US → Desktop
Whiteboard: [country-us] [notcontactready] [video]
WFM on Ubuntu 12.04 LTS.
Status: NEW → RESOLVED
Closed: 13 years ago8 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.