Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 472598 - Move firefox.js prefs to toolkit.js where necessary
: Move firefox.js prefs to toolkit.js where necessary
Status: RESOLVED DUPLICATE of bug 335931
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Jared Wein [:jaws] (please needinfo? me)
Depends on: 472603 472605
  Show dependency treegraph
Reported: 2009-01-07 17:28 PST by Ed Lee :Mardak
Modified: 2010-06-18 17:39 PDT (History)
9 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

quick pass toolkit used prefs (21.29 KB, text/plain)
2009-01-07 17:28 PST, Ed Lee :Mardak
no flags Details

Description Ed Lee :Mardak 2009-01-07 17:28:12 PST
Created attachment 355903 [details]
quick pass toolkit used prefs

There are a bunch of prefs in firefox.js that are needed by toolkit stuff. This causes problems for other toolkit users because there won't be defaults set.

Attached is a quick pass of which firefox.js prefs are being used under the toolkit directory. Some prefs aren't caught because they're using a prefbranch. Some prefs are only used in testcases, but that's still a use of the pref.

There are a bunch of browser.urlbar.* prefs that don't have a usage file listed because of the pref branch.
Comment 1 Ed Lee :Mardak 2009-01-07 17:34:43 PST
Gavin suggests that we just use all.js as there's no special toolkit.js prefs file.

Comment 2 Ed Lee :Mardak 2010-06-18 17:39:38 PDT

*** This bug has been marked as a duplicate of bug 335931 ***

Note You need to log in before you can comment on or make changes to this bug.